summaryrefslogtreecommitdiff
path: root/app-misc/timew-report/timew-report-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
commit47d5e233005d470dbd431a280e64ce6073fc7149 (patch)
tree135efe53d72c541429f68d7ed82186f2b34fcdb6 /app-misc/timew-report/timew-report-1.4.0-r1.ebuild
parentbac9556f73da9ac333933778ce81c053bd989a26 (diff)
gentoo auto-resync : 09:04:2023 - 23:35:30
Diffstat (limited to 'app-misc/timew-report/timew-report-1.4.0-r1.ebuild')
-rw-r--r--app-misc/timew-report/timew-report-1.4.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/timew-report/timew-report-1.4.0-r1.ebuild b/app-misc/timew-report/timew-report-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..7a298dbc18c1
--- /dev/null
+++ b/app-misc/timew-report/timew-report-1.4.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An interface for Timewarrior report data"
+HOMEPAGE="
+ https://github.com/lauft/timew-report/
+ https://pypi.org/project/timew-report/
+"
+SRC_URI="
+ https://github.com/lauft/timew-report/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-misc/timew
+"
+BDEPEND="
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest