summaryrefslogtreecommitdiff
path: root/app-misc/sphinx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /app-misc/sphinx
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/Manifest1
-rw-r--r--app-misc/sphinx/sphinx-2.2.11-r2.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/app-misc/sphinx/Manifest b/app-misc/sphinx/Manifest
index 1a221a42e675..1666f0d624a2 100644
--- a/app-misc/sphinx/Manifest
+++ b/app-misc/sphinx/Manifest
@@ -4,5 +4,6 @@ DIST sphinx-2.1.9-release.tar.gz 2443797 BLAKE2B d741d0bc915ece01c3ddcbfacd44f34
DIST sphinx-2.2.11-release.tar.gz 3061998 BLAKE2B 63abdf3d08046ebafcdfd67d3445325b9b127e4dd66ba9d36b3b7053ba80f1f3308b74fd1e01caae6174850e1db22c743454894584bad4a4bec78d533a002668 SHA512 cf1a262a5b0fbf0bd2827ec6ec629edeaf709ce855a6e7b509b65342baaeb26c02717ca63f1578d32c83d21e2fd6d1e92dceb34660e6351b93cd96fd4e623689
EBUILD sphinx-2.1.9.ebuild 2376 BLAKE2B 996c4d2a42f92a73a74baa7716abd352b2fa446373dbdeff5f936e9eb7db664df2584ffa17e09f315d2f26558e41f0699691545721bed32ed4ab1c976c8e1265 SHA512 79c16793a6c613234adc6f892ecbf939c8431bdb76f685501872328113618beea8d1d5181eb4ab1a53b91b9e00cb1b9bc681d1c9462894078b5f45aa708e6ab0
EBUILD sphinx-2.2.11-r1.ebuild 2773 BLAKE2B e9d0bb5f8dade5b9802160be4477b7d514f372357816607fd15ef497d9f9bb82b9b0a44d8a657a9219280113d7abed9fc1599f86027a312f2d2faf8ab8d7646f SHA512 20e0e2819a83b609623dc62887f09d9ea1a6eb93a533370f8f8b21ebcebb1869839171e238b0bedffda722e405d0ffb140dc5d31d22d8bef770a6737840c635f
+EBUILD sphinx-2.2.11-r2.ebuild 2834 BLAKE2B a156eb985d880af6f736c8c7a88641bdde1ff27e8f0d0810415d4ad49e8e2d2a9882ce50f69b13ad8c06eac15ab30ac9b38e5393742c466d6116de8cbba8b4a4 SHA512 14247d5c38bbb6d46aa275d991e53aa3fe834b3e1f2a810e81b380f73b4488c390535c272b6df48a258e8062162a03280772095c37331d6d8ff7156c4a17f170
EBUILD sphinx-2.2.11.ebuild 2403 BLAKE2B d48c34fd604e6df0c652845bedb1f2c35046c1db6601ed995602fbfbd042a035d7296c1824eb29cd611d35408d821fb2c3cfb75b14ed87c865d416fe8806ac8a SHA512 6be2c83feb3edfa0c4b8fc80311fcf17099215da2006e706df7c5f556b248bcd269fa9f5aa752d0466c5bb6cdf656af0c4562ef9783c40bcbe84207b7a264585
MISC metadata.xml 495 BLAKE2B 6ce04a8baaefb4f99722a9880c05774fae70dac6af652e31ba3e64f057cf7fe923aa035894673f5570bcfc98df0992e3f9a03ef22b5c5991fdab36eeb54dbaf2 SHA512 40351ff70a81c80367af1f1454fc18a1da6ff3e9f5d921547f40d4c05ab36fc0f13228176e54237956de7ca8ee78c3d14facd15c85171c39c03867eb2288d975
diff --git a/app-misc/sphinx/sphinx-2.2.11-r2.ebuild b/app-misc/sphinx/sphinx-2.2.11-r2.ebuild
new file mode 100644
index 000000000000..ed278ee1e82d
--- /dev/null
+++ b/app-misc/sphinx/sphinx-2.2.11-r2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WANT_AUTOMAKE=1.15
+
+inherit eutils autotools toolchain-funcs
+
+#MY_P=${P/_/-}
+MY_P=${P}-release
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug +id64 mariadb mysql odbc postgres re2 stemmer syslog xml"
+
+REQUIRED_USE="mysql? ( !mariadb ) mariadb? ( !mysql )"
+
+RDEPEND="
+ mysql? ( dev-db/mysql-connector-c )
+ mariadb? ( dev-db/mariadb-connector-c )
+ postgres? ( dev-db/postgresql:* )
+ odbc? ( dev-db/unixODBC )
+ re2? ( dev-libs/re2 )
+ stemmer? ( dev-libs/snowball-stemmer )
+ xml? ( dev-libs/expat )
+ virtual/libiconv"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1_beta-darwin8.patch
+
+ # drop nasty hardcoded search path breaking Prefix
+ # We patch configure directly since otherwise we need to run
+ # eautoreconf twice and that causes problems, bug 425380
+ sed -i -e 's/\/usr\/local\//\/someplace\/nonexisting\//g' configure || die
+
+ if use mariadb ; then
+ sed -i -e 's/mysql_config/mariadb_config/g' configure || die
+ fi
+
+ # Fix QA compilation warnings.
+ sed -i -e '19i#include <string.h>' api/libsphinxclient/test.c || die
+
+ eapply_user
+
+ pushd api/libsphinxclient || die
+ eautoreconf
+ popd || die
+
+ # Drop bundled code to ensure building against system versions. We
+ # cannot remove libstemmer_c since configure updates its Makefile.
+ rm -rf libexpat libre2 || die
+}
+
+src_configure() {
+ # fix libiconv detection
+ use !elibc_glibc && export ac_cv_search_iconv=-liconv
+
+ local mysql_with
+ if use mysql || use mariadb ; then
+ mysql_with="--with-mysql"
+ else
+ mysql_with="--without-mysql"
+ fi
+
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
+ ${mysql_with} \
+ $(use_with odbc unixodbc) \
+ $(use_with postgres pgsql) \
+ $(use_with re2) \
+ --with-re2-libs="${EPREFIX}/usr/$(get_libdir)/libre2.so" \
+ $(use_with stemmer libstemmer) \
+ $(use_with syslog syslog) \
+ $(use_with xml libexpat )
+
+ cd api/libsphinxclient || die
+ econf STRIP=:
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" || die "emake failed"
+
+ emake -j 1 -C api/libsphinxclient || die "emake libsphinxclient failed"
+}
+
+src_test() {
+ # Tests require a live database and only work from the source
+ # directory.
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" -C api/libsphinxclient install || die "install libsphinxclient failed"
+
+ dodoc doc/*
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+
+ newinitd "${FILESDIR}"/searchd.rc searchd
+}