summaryrefslogtreecommitdiff
path: root/app-misc/socnetv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/socnetv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/socnetv')
-rw-r--r--app-misc/socnetv/Manifest4
-rw-r--r--app-misc/socnetv/files/socnetv-2.2-deps.patch10
-rw-r--r--app-misc/socnetv/metadata.xml19
-rw-r--r--app-misc/socnetv/socnetv-2.2.ebuild45
4 files changed, 78 insertions, 0 deletions
diff --git a/app-misc/socnetv/Manifest b/app-misc/socnetv/Manifest
new file mode 100644
index 000000000000..b73659900d1c
--- /dev/null
+++ b/app-misc/socnetv/Manifest
@@ -0,0 +1,4 @@
+AUX socnetv-2.2-deps.patch 218 BLAKE2B 8f9900b1f9a6d6e9e4a116d3da75aa743d7a193dce8136582eabfa9c183209d4ead2fa782d7cefa5366eb98f1a5e29ac20c8f0b2350982856c05826130b63fc4 SHA512 30fa3fda847aee54452ebbbaea8ae2439dc99fd5b79bdd41517d12effaf2a8e1355257b00e80dabb40e1502a169a8b46bbb98af8ead5239731d35a75b847db03
+DIST SocNetV-2.2.tar.gz 745086 BLAKE2B 3b520df2bb29f1989f744ec7e424caecd722cf3f903cf494e0fba9c0e5c1def413411768f593a3f8c0eb3cc20d1071d54babbd76eb24aac9f6670b4f2623ceb7 SHA512 12f490fd1f7fc1a6b45f77d23d8825117def0b7720595cd203d171fd88c41d5a0194a70359f55cbe2dab9e545f300156b31bb0680e46d7ab584e070e128e457b
+EBUILD socnetv-2.2.ebuild 820 BLAKE2B 94f3edb120792ed47a24bf70b82ef0505ac1bbace4fd81e1e9598dab12a5e8756bf97b6fd40c5bfed5bac2fe0519d9b6d7f09ab1a8cd280e6ca4b385188b328f SHA512 0a441336e37567f1e1fa1311269067e7601a475c336186b5916dd39d387f1993667247c35abae9e9c673dab53451feb954c692d21fb3848fffa6b4bac4058158
+MISC metadata.xml 871 BLAKE2B ecddd2e7e36a5efa541f554f2ad33ec02570765a02bc00cd7ad8304613a5acf78a783252c6d36bea2edb90334b17ba83709c21cb16cef223cc7cb9bf0570fafa SHA512 d387eeb7d713e4f43f5232f1edba34dc5676c58797838b51301ffed8daf70312117e15c05ce783ba5888cb121b6e8451318c229a998acecedbe6f5fa7aa1120a
diff --git a/app-misc/socnetv/files/socnetv-2.2-deps.patch b/app-misc/socnetv/files/socnetv-2.2-deps.patch
new file mode 100644
index 000000000000..080ff93564a6
--- /dev/null
+++ b/app-misc/socnetv/files/socnetv-2.2-deps.patch
@@ -0,0 +1,10 @@
+--- a/socnetv.pro 2017-01-21 16:50:53.000000000 +0100
++++ b/socnetv.pro 2017-01-28 15:05:26.462351261 +0100
+@@ -34,7 +34,6 @@
+ LANGUAGE = C++
+
+ # support
+-QT += xml
+ QT += network
+ QT += widgets
+ QT += printsupport
diff --git a/app-misc/socnetv/metadata.xml b/app-misc/socnetv/metadata.xml
new file mode 100644
index 000000000000..7831ad505653
--- /dev/null
+++ b/app-misc/socnetv/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+ Social Networks Visualizer (SocNetV) is a flexible and user-friendly tool for
+ the analysis and visualization of Social Networks. It lets you construct networks
+ (mathematical graphs) with a few clicks on a virtual canvas or load networks of
+ various formats (GraphViz, GraphML, Adjacency, Pajek, UCINET, etc) and modify them
+ to suit your needs. SocNetV also offers a built-in web crawler, allowing you to
+ automatically create networks from all links found in a given initial URL.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">socnetv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/socnetv/socnetv-2.2.ebuild b/app-misc/socnetv/socnetv-2.2.ebuild
new file mode 100644
index 000000000000..6de2120eae44
--- /dev/null
+++ b/app-misc/socnetv/socnetv-2.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils qmake-utils toolchain-funcs
+
+MY_PN="SocNetV"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt Social Network Visualizer"
+HOMEPAGE="http://socnetv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/socnetv/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}"-deps.patch )
+
+src_configure() {
+ eqmake5 socnetv.pro
+}
+
+src_install() {
+ default
+ dobin socnetv
+ doicon src/images/socnetv.png
+ domenu ${PN}.desktop
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins nets/*
+ fi
+ doman "${S}/man/${PN}.1.gz"
+}