summaryrefslogtreecommitdiff
path: root/app-misc/sleepyhead
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/sleepyhead
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/sleepyhead')
-rw-r--r--app-misc/sleepyhead/Manifest4
-rw-r--r--app-misc/sleepyhead/files/common_gui.patch12
-rw-r--r--app-misc/sleepyhead/metadata.xml11
-rw-r--r--app-misc/sleepyhead/sleepyhead-1.0.0_beta2.ebuild53
4 files changed, 80 insertions, 0 deletions
diff --git a/app-misc/sleepyhead/Manifest b/app-misc/sleepyhead/Manifest
new file mode 100644
index 000000000000..2f32955f44dc
--- /dev/null
+++ b/app-misc/sleepyhead/Manifest
@@ -0,0 +1,4 @@
+AUX common_gui.patch 246 BLAKE2B f4b6c9889322f709a19673529d61d8719a55c692d9aeeb2a174ae86134fffc2216a77002ddd1544326e97ad8c0685c8311ad81fe660b22120c47718275b3be29 SHA512 952027395ac82fa3960c5efe9b98acf4a2232380a59fd9d71112ea57d26c94fc9f497e9c1c6e6fd48820f3042b16cc88d9f8b95285e857f1b5580a7e00acf442
+DIST sleepyhead-1.0.0_beta2.tar.bz2 3404013 BLAKE2B a5cf9fcb6a1c91786fffd2cbb2505ebc9608d83f5b6fc4e39fcf74def369a6fd1a40e23bf164c840956a9fe2f2c25ccf7313a95098eb6829632971a6a924ff61 SHA512 147a853bd77e6277b70d5d70f9b82f46c3f6328283c30b38d77e698146519367c9fa02f8fb21c687237657ceb78d7bc9ee07e4e8ccdbe41652ddd8dc55049eca
+EBUILD sleepyhead-1.0.0_beta2.ebuild 1177 BLAKE2B ba5fdec1915a40512342e4423611808770ec6646f9311e8ffa48615e883bbb9f2282fa4db65b71c78f864b0e5b7314fb088ca7c7182823d4a4a88d197a8057a4 SHA512 cc0e8514e6eec60d3aaa0aa0571ee779b79c4ef53237b34288cf3a05973ecb0d321ce6c74511e03d3e40cbc7abe1bab221cef5755b69df18cdbcc2469b7126c9
+MISC metadata.xml 409 BLAKE2B 1777997bf87537da1a8337390065482b53fc2acae84137ebbc54fd13b221b8fc9c48a799ac9efcc6e4853f3610bab85a44679b5780fabaa0b46e1c5e20cedab9 SHA512 bd3522a2a682e51f61f5c38db6003365e06226a2015fe2aa81ed638852a663084da4d4d39962abb36aacc37462d84b706e4b35023e265635904a4d1874044ae8
diff --git a/app-misc/sleepyhead/files/common_gui.patch b/app-misc/sleepyhead/files/common_gui.patch
new file mode 100644
index 000000000000..6e41e0ac4ce9
--- /dev/null
+++ b/app-misc/sleepyhead/files/common_gui.patch
@@ -0,0 +1,12 @@
+diff --git a/common_gui.cpp b/common_gui.cpp
+index 0f38ce8..36b0b9e 100644
+--- a/common_gui.cpp
++++ b/common_gui.cpp
+@@ -6,6 +6,7 @@
+
+ #include "common_gui.h"
+ #include "qglobal.h"
++#include <unistd.h>
+
+ #ifdef Q_WS_WIN32
+ #include "windows.h"
diff --git a/app-misc/sleepyhead/metadata.xml b/app-misc/sleepyhead/metadata.xml
new file mode 100644
index 000000000000..cabb7c423f61
--- /dev/null
+++ b/app-misc/sleepyhead/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ </maintainer>
+ <longdescription>QT-based application used to analyze data from various CPAP machines.</longdescription>
+ <upstream>
+ <remote-id type="github">rich0/rich0-sleepyhead</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/sleepyhead/sleepyhead-1.0.0_beta2.ebuild b/app-misc/sleepyhead/sleepyhead-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..779450ed1051
--- /dev/null
+++ b/app-misc/sleepyhead/sleepyhead-1.0.0_beta2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils qmake-utils
+DESCRIPTION="Software used to analyze data from CPAP machines"
+HOMEPAGE="https://sleepyhead.jedimark.net/"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="https://gitlab.com/sleepyhead/sleepyhead-code/repository/archive.tar.bz2?ref=1.0.0-beta-2 -> ${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE=""
+
+DEPEND="virtual/opengl
+ x11-libs/libX11
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtserialport:5
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/sleepyhead-code-1.0.0-beta-2-6b1c125218475720e1bf7c920ed3d10140b0b7c2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_prepare() {
+ eapply_user
+ rm configure
+ cd "${S}/3rdparty/quazip/"
+# epatch "${FILESDIR}/common_gui.patch"
+
+ sed -i '1i#define OF(x) x' quazip/ioapi.h quazip/unzip.c quazip/unzip.h \
+ quazip/zip.c quazip/zip.h
+ cd "${S}"
+ eqmake5 SleepyHeadQT.pro
+}
+
+src_install() {
+ cd "${S}/sleepyhead"
+ dobin SleepyHead || die
+ dodoc ../README || die
+ dodoc docs/* || die
+}