summaryrefslogtreecommitdiff
path: root/app-misc/selecta
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/selecta
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/selecta')
-rw-r--r--app-misc/selecta/Manifest4
-rw-r--r--app-misc/selecta/metadata.xml12
-rw-r--r--app-misc/selecta/selecta-0.0.7.ebuild28
-rw-r--r--app-misc/selecta/selecta-9999.ebuild28
4 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/selecta/Manifest b/app-misc/selecta/Manifest
new file mode 100644
index 000000000000..3c5193912a15
--- /dev/null
+++ b/app-misc/selecta/Manifest
@@ -0,0 +1,4 @@
+DIST selecta-0.0.7.tar.gz 116987 BLAKE2B dda7f21ad939780a1d631086eb669f4824277c9b9bc4a762fa56e201fca3202ee8fab63ea1328dfabf868f4c430456969be99ec1520afcb8c509518f589a3a6a SHA512 7db8fefa51411c6b9996bd1e19889902e807471bb76309bbcace16dcfae70cdb71bdd7abd2c1a96b99d2fe1f9ecbdb1972e95485a2d06b3e3258303a0fef2018
+EBUILD selecta-0.0.7.ebuild 612 BLAKE2B f5392d93eb8e00563aa659649071c8d4f75caa73276dc177e975e01a49530a5542c03f7dcefa168e12b831a7244e0b96d72bb22f6131eb44177c3287cbb876bc SHA512 882a115d5702e7def5b7139688caea83ce853d044bcd59e4814501e32cf323c3b8259a61a646f6ebf73cd047666493ef9826e7a2204ffc7a3cdc7f5a70390296
+EBUILD selecta-9999.ebuild 612 BLAKE2B f5392d93eb8e00563aa659649071c8d4f75caa73276dc177e975e01a49530a5542c03f7dcefa168e12b831a7244e0b96d72bb22f6131eb44177c3287cbb876bc SHA512 882a115d5702e7def5b7139688caea83ce853d044bcd59e4814501e32cf323c3b8259a61a646f6ebf73cd047666493ef9826e7a2204ffc7a3cdc7f5a70390296
+MISC metadata.xml 364 BLAKE2B dd954ec6767c68a6ae792b545fe4a11b15630bb77445e146aef6577f71a05d01cf52a8b6afac6dd304ed0d9429453edb16b3f47008b411f331e786bd33c01efd SHA512 542d4cde25dd2756b2927d22dab88cfd2b086b01fcfeafe93aa9bddcbc7b2878e2e048d379572bd06a59440c2b5b255d43dfb7dc8e1e4ce59a07ae7622948845
diff --git a/app-misc/selecta/metadata.xml b/app-misc/selecta/metadata.xml
new file mode 100644
index 000000000000..6bf484adc0d0
--- /dev/null
+++ b/app-misc/selecta/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lucianposton@pm.me</email>
+ <name>Lucian Poston</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/selecta/selecta-0.0.7.ebuild b/app-misc/selecta/selecta-0.0.7.ebuild
new file mode 100644
index 000000000000..102d07f58dd5
--- /dev/null
+++ b/app-misc/selecta/selecta-0.0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/garybernhardt/selecta"
+else
+ SRC_URI="https://github.com/garybernhardt/selecta/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A fuzzy text selector for files and anything else you need to select"
+HOMEPAGE="https://github.com/garybernhardt/selecta"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=dev-lang/ruby-1.9.3"
+
+src_install() {
+ dobin selecta
+ einstalldocs
+}
diff --git a/app-misc/selecta/selecta-9999.ebuild b/app-misc/selecta/selecta-9999.ebuild
new file mode 100644
index 000000000000..102d07f58dd5
--- /dev/null
+++ b/app-misc/selecta/selecta-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/garybernhardt/selecta"
+else
+ SRC_URI="https://github.com/garybernhardt/selecta/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A fuzzy text selector for files and anything else you need to select"
+HOMEPAGE="https://github.com/garybernhardt/selecta"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=dev-lang/ruby-1.9.3"
+
+src_install() {
+ dobin selecta
+ einstalldocs
+}