summaryrefslogtreecommitdiff
path: root/app-misc/screenfetch/screenfetch-3.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-misc/screenfetch/screenfetch-3.9.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-misc/screenfetch/screenfetch-3.9.1.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-3.9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/screenfetch/screenfetch-3.9.1.ebuild b/app-misc/screenfetch/screenfetch-3.9.1.ebuild
new file mode 100644
index 000000000000..552e3a0655c6
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-3.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/f/F}"
+
+DESCRIPTION="Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+ SRC_URI="https://github.com/KittyKatt/screenFetch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="curl X"
+
+DEPEND=""
+RDEPEND="
+ curl? ( net-misc/curl )
+ X? (
+ media-gfx/scrot
+ x11-apps/xdpyinfo
+ )"
+
+src_install() {
+ newbin ${PN}-dev ${PN}
+ einstalldocs
+}