summaryrefslogtreecommitdiff
path: root/app-misc/screen/screen-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-misc/screen/screen-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-misc/screen/screen-9999.ebuild')
-rw-r--r--app-misc/screen/screen-9999.ebuild35
1 files changed, 14 insertions, 21 deletions
diff --git a/app-misc/screen/screen-9999.ebuild b/app-misc/screen/screen-9999.ebuild
index e41146f416bf..abdf2c2458a2 100644
--- a/app-misc/screen/screen-9999.ebuild
+++ b/app-misc/screen/screen-9999.ebuild
@@ -1,49 +1,42 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools flag-o-matic pam tmpfiles toolchain-funcs
+inherit autotools flag-o-matic pam tmpfiles
DESCRIPTION="screen manager with VT100/ANSI terminal emulation"
HOMEPAGE="https://www.gnu.org/software/screen/"
-if [[ "${PV}" != 9999 ]] ; then
+if [[ ${PV} != 9999 ]] ; then
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
else
inherit git-r3
EGIT_REPO_URI="https://git.savannah.gnu.org/git/screen.git"
EGIT_CHECKOUT_DIR="${WORKDIR}/${P}" # needed for setting S later on
- S="${WORKDIR}/${P}/src"
+ S="${WORKDIR}"/${P}/src
fi
LICENSE="GPL-2"
SLOT="0"
IUSE="debug nethack pam selinux multiuser"
-CDEPEND="
- >=sys-libs/ncurses-5.2:0=
+DEPEND=">=sys-libs/ncurses-5.2:=
virtual/libcrypt:=
pam? ( sys-libs/pam )"
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
acct-group/utmp
selinux? ( sec-policy/selinux-screen )"
-DEPEND="${CDEPEND}
- sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
PATCHES=(
# Don't use utempter even if it is found on the system.
- "${FILESDIR}"/${PN}-4.3.0-no-utempter.patch
- "${FILESDIR}"/${PN}-4.6.2-utmp-exit.patch
+ "${FILESDIR}"/${P}-no-utempter.patch
)
src_prepare() {
- if [[ "${PV}" != *9999 ]] ; then
- default
- else
- eapply_user
- fi
+ default
# sched.h is a system header and causes problems with some C libraries
mv sched.h _sched.h || die
@@ -51,7 +44,7 @@ src_prepare() {
screen.h winmsg.c window.h sched.c canvas.h || die
sed -i 's@[[:space:]]sched\.h@ _sched.h@' Makefile.in || die
- # Fix manpage.
+ # Fix manpage
sed -i \
-e "s:/usr/local/etc/screenrc:${EPREFIX}/etc/screenrc:g" \
-e "s:/usr/local/screens:${EPREFIX}/tmp/screen:g" \
@@ -60,7 +53,7 @@ src_prepare() {
-e "s:/local/screens/S\\\-:${EPREFIX}/tmp/screen/S\\\-:g" \
doc/screen.1 || die
- if [[ ${CHOST} == *-darwin* ]] || use elibc_musl ; then
+ if [[ ${CHOST} == *-darwin* ]] || use elibc_musl; then
sed -i -e '/^#define UTMPOK/s/define/undef/' acconfig.h || die
fi
@@ -74,7 +67,7 @@ src_prepare() {
src_configure() {
append-cppflags "-DMAXWIN=${MAX_SCREEN_WINDOWS:-100}"
- if [[ ${CHOST} == *-solaris* ]] ; then
+ if [[ ${CHOST} == *-solaris* ]]; then
# enable msg_header by upping the feature standard compatible
# with c99 mode
append-cppflags -D_XOPEN_SOURCE=600
@@ -89,6 +82,7 @@ src_configure() {
--with-pty-mode=0620
--with-pty-group=5
--enable-telnet
+ --enable-utmp
$(use_enable pam)
)
econf "${myeconfargs[@]}"
@@ -138,8 +132,7 @@ src_install() {
}
pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]
- then
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Some dangerous key bindings have been removed or changed to more safe values."
elog "We enable some xterm hacks in our default screenrc, which might break some"
elog "applications. Please check /etc/screenrc for information on these changes."