summaryrefslogtreecommitdiff
path: root/app-misc/reptyr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/reptyr
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/reptyr')
-rw-r--r--app-misc/reptyr/Manifest4
-rw-r--r--app-misc/reptyr/metadata.xml15
-rw-r--r--app-misc/reptyr/reptyr-0.6.2.ebuild39
3 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/reptyr/Manifest b/app-misc/reptyr/Manifest
new file mode 100644
index 000000000000..d4867138c25d
--- /dev/null
+++ b/app-misc/reptyr/Manifest
@@ -0,0 +1,4 @@
+DIST reptyr-0.6.2-sysmacros.patch 598 BLAKE2B 12e024efd3a7c2e07f1930545f2c5ee78212ac0f30095208c7cd2678c66f48038576d32b1f969cf9018db12b8fcd27f900257701bc66873326cd820c2ee57c14 SHA512 2d6c711a1d1268557925d15cf5d8154bc4ce47b5475ad05a5d358fd94a882991f33a8d99608e511d15dea6c08dcac615467f52bedb46330868540b03302e0cc9
+DIST reptyr-0.6.2.tar.gz 28533 BLAKE2B 305aeb5619c1780bbc189a64786ba1148c730e518ea8fe3c5daf715fcbe0de3ad7bd107008fb2471b8a3b61e75406ebb32d99b2eb5323badbb9e5f10ed1e65dc SHA512 ad0b378d3c30bbfaa30dfcc06c405c375c7e9bcc3bae2e7fb97b8c3f88f482f461c9c846df0064cc842149b07b8a6b616d95f74cdf38f1b2a5011f6b9328c327
+EBUILD reptyr-0.6.2.ebuild 952 BLAKE2B d3b5e34cc1989043a47e8d13eb066fb588688a588c256efc29991f625c01409a3e01178342a4373f2996467643395031ea30187cf1efbf80366b095677fc884d SHA512 6b70da39e56db290e52af8589437452214f458e8d28487f796000ddb4036427a798f0b38f4766860e3fc0cabdc26248823d18deb78ce80ac9a073a0b4d0cb57d
+MISC metadata.xml 472 BLAKE2B 60fe70a0a1d8761764b853a0b6a05656019e3e4c9d04a7b79b884d35b9bb112a0aa66ae4b7096d91c25fafc34dd6ea248119887eb0a44c132b7b38c6fe993d87 SHA512 6b0c72aca4cc7c33cc37aa366292889fb6907d10c6e31bb140c98b30b1bde79a81dd188d5b2b5a1eb338ca8ebb41d05c2fe9d5158d780fa4cf3ea772476166ff
diff --git a/app-misc/reptyr/metadata.xml b/app-misc/reptyr/metadata.xml
new file mode 100644
index 000000000000..c5eb1454b5dd
--- /dev/null
+++ b/app-misc/reptyr/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nelhage/reptyr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/reptyr/reptyr-0.6.2.ebuild b/app-misc/reptyr/reptyr-0.6.2.ebuild
new file mode 100644
index 000000000000..40892b3d1a67
--- /dev/null
+++ b/app-misc/reptyr/reptyr-0.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic vcs-snapshot
+
+DESCRIPTION="A utility to attach a running program to a new terminal"
+HOMEPAGE="https://github.com/nelhage/reptyr"
+SRC_URI="https://github.com/nelhage/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+# https://github.com/nelhage/reptyr/issues/81
+SRC_URI+=" https://github.com/nelhage/reptyr/commit/b45fd9238958fcf2d8f3d6fc23e6d491febea2ac.patch -> ${PN}-0.6.2-sysmacros.patch"
+
+PATCHES=(
+ "${DISTDIR}/${P}-sysmacros.patch" #581974
+)
+
+src_prepare() {
+ default
+ # respect CFLAGS
+ sed -i '/^override/d' Makefile || die
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc ChangeLog NOTES README.md
+}