summaryrefslogtreecommitdiff
path: root/app-misc/remind/remind-03.01.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/remind/remind-03.01.15.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/remind/remind-03.01.15.ebuild')
-rw-r--r--app-misc/remind/remind-03.01.15.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/remind/remind-03.01.15.ebuild b/app-misc/remind/remind-03.01.15.ebuild
new file mode 100644
index 000000000000..a1ad5d91383c
--- /dev/null
+++ b/app-misc/remind/remind-03.01.15.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Ridiculously functional reminder program"
+HOMEPAGE="http://www.roaringpenguin.com/products/remind"
+SRC_URI="http://www.roaringpenguin.com/files/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="tk"
+
+RDEPEND="tk? ( dev-lang/tk dev-tcltk/tcllib )"
+
+DOCS="docs/WHATSNEW examples/defs.rem www/README.*"
+
+src_prepare() {
+ sed -i 's:$(MAKE) install:&-nostripped:' "${S}"/Makefile || die
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ ewarn "Testing fails if run as root. Skipping tests."
+ else
+ emake test
+ fi
+}
+
+src_install() {
+ default
+ dobin www/rem2html
+
+ if ! use tk ; then
+ rm "${D}"/usr/bin/tkremind "${D}"/usr/share/man/man1/tkremind* \
+ "${D}"/usr/bin/cm2rem* "${D}"/usr/share/man/man1/cm2rem*
+ fi
+
+ rm "${S}"/contrib/rem2ics-*/{Makefile,rem2ics.spec} || die
+ insinto /usr/share/${PN}
+ doins -r contrib/
+}