summaryrefslogtreecommitdiff
path: root/app-misc/regionset/regionset-0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-misc/regionset/regionset-0.1-r1.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'app-misc/regionset/regionset-0.1-r1.ebuild')
-rw-r--r--app-misc/regionset/regionset-0.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/regionset/regionset-0.1-r1.ebuild b/app-misc/regionset/regionset-0.1-r1.ebuild
new file mode 100644
index 000000000000..5622745866fe
--- /dev/null
+++ b/app-misc/regionset/regionset-0.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sets the region on DVD drives"
+HOMEPAGE="http://linvdr.org/projects/regionset/"
+SRC_URI="http://linvdr.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c dvd_udf.c || die
+}
+
+src_install() {
+ dosbin regionset || die
+ dodoc ChangeLog README || die
+}
+
+pkg_postinst() {
+ ewarn "By default regionset uses /dev/dvd, specify a different device"
+ ewarn "as a command line argument if you need to. You need write access"
+ ewarn "to do this, preferably as root."
+ ewarn
+ ewarn "Most drives can only have their region changed 4 or 5 times."
+ ewarn
+ ewarn "When you use regionset, you MUST have a cd or dvd in the drive"
+ ewarn "otherwise nasty things will happen to your drive's firmware."
+}