summaryrefslogtreecommitdiff
path: root/app-misc/recoll
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
commit99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (patch)
tree9bf7a2d385aace0ea5f3f8d3e3657168b758fdaa /app-misc/recoll
parent39bccce90513402ec93bb0fde30678f16b07a9cc (diff)
gentoo auto-resync : 08:07:2023 - 22:23:22
Diffstat (limited to 'app-misc/recoll')
-rw-r--r--app-misc/recoll/Manifest2
-rw-r--r--app-misc/recoll/recoll-1.35.0.ebuild128
2 files changed, 130 insertions, 0 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 22aa712853b6..40aa0a2aeba9 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1,3 +1,5 @@
DIST recoll-1.34.6.tar.gz 3078366 BLAKE2B 91ae9e72851b008da61e41a1ddd5091b20b3e683506970e01f39eb2e3b5dfc174ebbc213ef29daede601322b21783ea34e34e04992447375015189c8fdec9d71 SHA512 f151a8f3575af41277fc9b50bb9a5e2ea1348e035b3dead36b47d1d6918deb755a4d59913d174db48273afdd95f4a063aa20219f1116a6d83c82fb063dbf16b7
+DIST recoll-1.35.0.tar.gz 3121862 BLAKE2B ede6f404cfc3b672d80d2d16303174ca88bce72dd0745ab24a5cddb41db3e813ce60e4a6f5c8cb0a394320f727b3c5df4a3a84d9c9220bc704f2fa0ce66e2120 SHA512 35dcbfb650251b00f2c7654dc7617bf24f7e480955121821c55e0d31c6ec4fa041f8f99e64afa12ad4ead725c366084d7d727dbdcee875b93bbc858a6229d236
EBUILD recoll-1.34.6-r1.ebuild 3159 BLAKE2B 63c5a4c5a845677b77c16ec89181dbd3607d39181a29204e80b85ae656ef01dd6c2bdea8b70fb6301af94fc8c4f61b898855f216b0f3bd682a479cdad11b296e SHA512 4df746aad3530d44b2afba5664d36d38481965763451d89bc91d8fd33fb965626c8ccd0470c6631bc1851e97b2815a104255263a193f887ac13bb6f395952b42
+EBUILD recoll-1.35.0.ebuild 3159 BLAKE2B 63c5a4c5a845677b77c16ec89181dbd3607d39181a29204e80b85ae656ef01dd6c2bdea8b70fb6301af94fc8c4f61b898855f216b0f3bd682a479cdad11b296e SHA512 4df746aad3530d44b2afba5664d36d38481965763451d89bc91d8fd33fb965626c8ccd0470c6631bc1851e97b2815a104255263a193f887ac13bb6f395952b42
MISC metadata.xml 1413 BLAKE2B ffeeae4a0a0d5553e7ee8bffc85262eff920ca0d2ee2c8db767662f6f37c4b9702123fdf1cc1f804e9d646819d8523a360018813233ec6277d9d4d819397a67e SHA512 855cbf30c1d6216d52c1655ed20caf622ce835a6c9c0798b871206c29e946bdde2759e25f2d3003c0c8478d8cda78b28f1c3c0435db26001b0ea323858355a69
diff --git a/app-misc/recoll/recoll-1.35.0.ebuild b/app-misc/recoll/recoll-1.35.0.ebuild
new file mode 100644
index 000000000000..35740531753b
--- /dev/null
+++ b/app-misc/recoll/recoll-1.35.0.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit linux-info optfeature python-single-r1 qmake-utils systemd
+
+DESCRIPTION="Personal full text search package"
+HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
+SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+IUSE="camelcase chm +inotify qt5 session +spell systemd webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt5 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xapian:=
+ sys-libs/zlib
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ systemd? ( sys-apps/systemd )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ local myeconfargs=(
+ $(use_enable camelcase)
+ $(use_enable chm python-chm)
+ $(use_enable session x11mon)
+ $(use_enable qt5 qtgui)
+ $(use_enable spell python-aspell)
+ $(use_enable webengine)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ $(use_with systemd)
+ --with-system-unit-dir="$(systemd_get_systemunitdir)"
+ --with-user-unit-dir="$(systemd_get_userunitdir)"
+ --disable-webkit
+ --without-fam
+ --enable-recollq
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIP="$(type -P true || die)" DESTDIR="${D}" install
+ python_optimize
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" dev-text/detex
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}