summaryrefslogtreecommitdiff
path: root/app-misc/recoll
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /app-misc/recoll
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'app-misc/recoll')
-rw-r--r--app-misc/recoll/Manifest3
-rw-r--r--app-misc/recoll/files/recoll-python3.patch17
-rw-r--r--app-misc/recoll/recoll-1.23.6.ebuild122
3 files changed, 142 insertions, 0 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 90cd61f94829..d095aade0ef5 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1,3 +1,6 @@
+AUX recoll-python3.patch 473 BLAKE2B 78b15249de8b20a46e3331d90c52cc8987278d4c508480ceab35ee878c9467f796b209dca5eb0ed5637019718a5e0dc7a2888283b149041ffcedfc175419509c SHA512 50cd8bea004e2ee3a7b861b3b9bc981d5dc0656421894dc8f47777516f290aaaba4300eff52d01d496c873d0f135bfb39f2606a41e95a3dc4edd0a1195614774
DIST recoll-1.23.3.tar.gz 2590148 BLAKE2B ec058bac500aa61b4e395720bffcc2bfbcaded954c986e8e1fe69720456267c33b5e34eb3e28de47f57d9af207c60b138c521792882b093120b988b682600b2a SHA512 bfad118dd9561c8d18e194b11d8014e2f9ea74f6aaf50f91704087775e6f72d5f3574a3eafe470dab7658cb4a7233817a672af939f21b3e69c719e599bc5cd06
+DIST recoll-1.23.6.tar.gz 2601494 BLAKE2B e64ed422a1ac1a816091f9ee00ee23b551690f5038cf3378a00ebf39c9e4f4e22436105ed01a1aa2bc21b633c85a73ba2847a265e4d199109a8b0c03ec53421e SHA512 ae6f6dfe5e63faf2310b32bd0ffd90f08b12de7452ded9e5bd58a45690797caa9f5c66ea94ef94ed7a4ee3e55083cc191fbecfc112dbce42415d0af1300fe8fd
EBUILD recoll-1.23.3.ebuild 3530 BLAKE2B 2ab1153d20e6868ce8cf8f641a475957e51ca98ed322fe00edbafc9e8766639b5a91054bef716e628ea1e15300a73a629f7fef8251c30e666e5910bc56a1e462 SHA512 a37a458472a8c8b07f3c2d9b61bfed65e22d7f94622b941a0dc1cf1175bf57ffe5e49a063972490670b122adddc6471b01ed046560b237a9de0a2a7e2eef4724
+EBUILD recoll-1.23.6.ebuild 3543 BLAKE2B 7759c44f9c0325e2daa478f5c63e5c14c362031f4633ad0209c974ae81a3f362da655266df079de66b8c95871087753dcd8a921cafc52ce0456c085b53aa46a7 SHA512 0770d7316dd8d9385d8210e8bd10f2a4b4ef298880c1423226be366e79fc974abd7fc9bc5ec4ad8bb00126fd2f24ef58f5f6faa5f50c27ca1219efacff410085
MISC metadata.xml 1204 BLAKE2B a27afe4b6f800a38fa63956a750e4ddcd8ac2e9a785df910f660fce03357a77b37752e405be6d76fad74ce6f90d8564912499f397eb819535859ddc259cbc7a3 SHA512 581c483f1d64131cb7a83e9a899b5286f03cbacc3f011c5fcdb3236b56e2b22e1a0fa880b34bb107874fe03fde7f82767805bb7e2d0aa46367e8d5dca0037ea5
diff --git a/app-misc/recoll/files/recoll-python3.patch b/app-misc/recoll/files/recoll-python3.patch
new file mode 100644
index 000000000000..6d6fbdf39618
--- /dev/null
+++ b/app-misc/recoll/files/recoll-python3.patch
@@ -0,0 +1,17 @@
+--- a/filters/recoll-we-move-files.py
++++ b/filters/recoll-we-move-files.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python3
++#!/usr/bin/env python2
+ # Copyright (C) 2017 J.F.Dockes
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -42,6 +42,8 @@ try:
+ except:
+ import rclconfig
+
++from __future__ import print_function
++
+ verbosity = 0
+ def logdeb(s):
+ if verbosity >= 4:
diff --git a/app-misc/recoll/recoll-1.23.6.ebuild b/app-misc/recoll/recoll-1.23.6.ebuild
new file mode 100644
index 000000000000..685945ed2d2e
--- /dev/null
+++ b/app-misc/recoll/recoll-1.23.6.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils linux-info python-single-r1 qmake-utils
+
+DESCRIPTION="A personal full text search package"
+HOMEPAGE="http://www.lesbonscomptes.com/recoll/"
+SRC_URI="http://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="camelcase doc +inotify qt5 session +spell"
+REQUIRED_USE="session? ( inotify ) ${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ dev-libs/xapian:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebkit:5
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ ${PYTHON_DEPS}
+"
+
+DEPEND="
+ ${CDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${CDEPEND}
+ app-arch/unzip
+"
+
+PATCHES=( "${FILESDIR}/recoll-python3.patch" )
+
+pkg_setup() {
+ if has_version "<app-misc/recoll-1.20"; then
+ einfo "Installing ${PV} over an 1.19 index is possible,"
+ einfo "but there have been small changes in the way"
+ einfo "compound words are indexed. So it is best to reset"
+ einfo "the index. The best method to reset the index is to"
+ einfo "quit all recoll programs and delete the index directory"
+ einfo "rm -rf ~/.recoll/xapiandb, then start recoll or recollindex."
+ fi
+ if use inotify; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ econf \
+ $(use_enable camelcase) \
+ $(use_enable session x11mon) \
+ $(use_enable qt5 qtgui) \
+ $(use_enable qt5 webkit) \
+ $(use_with inotify) \
+ $(use_with spell aspell) \
+ --without-fam \
+ --enable-recollq
+}
+
+src_install() {
+ emake STRIP="$(type -P true)" DESTDIR="${D}" install
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ use doc && dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ einfo "In order to extract the full functionality of "
+ einfo "recoll, the following packages should be installed "
+ einfo "to get the corresponding document support."
+
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "CHM files support" dev-python/pychm
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" dev-text/detex
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}