summaryrefslogtreecommitdiff
path: root/app-misc/qtxdg-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
commit6a7029e0f7370d4d5dfe9e31cc2719a870482392 (patch)
tree28c6c747114eaedfd2db81f86ac2ff3d7d13111e /app-misc/qtxdg-tools
parent5e41a38157bb40e8513e8e34426e85faba672fe7 (diff)
gentoo auto-resync : 15:06:2024 - 00:09:17
Diffstat (limited to 'app-misc/qtxdg-tools')
-rw-r--r--app-misc/qtxdg-tools/Manifest2
-rw-r--r--app-misc/qtxdg-tools/qtxdg-tools-4.0.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/qtxdg-tools/Manifest b/app-misc/qtxdg-tools/Manifest
index 192504f23ef8..7dc674bb2f1a 100644
--- a/app-misc/qtxdg-tools/Manifest
+++ b/app-misc/qtxdg-tools/Manifest
@@ -1,5 +1,7 @@
DIST qtxdg-tools-3.11.0.tar.xz 16716 BLAKE2B ef6b88e69b0b4e8896ba37f7b5f663234a5348759d430600396432f4abb52901001c54ec78bd706efa021b51d9ff514457ff8e123d5142a6562cd380dd5a15ee SHA512 da88f36130b7c23d1553bce252ddc783ae30ba91cd55fba065702376f6cc9c0353c0ad4bb099ed1b65964bd9d476ae431bfde46df110bccec832d3f57cbaa7f3
DIST qtxdg-tools-3.12.0.tar.xz 16740 BLAKE2B 3e716c85d1715b23001d32a301995d77351f6f95ceaa80a0fa6c1ac1713029b8df97324ac550032fe88315b0fc89adc72b705b1580923f5838c48384222f48a4 SHA512 a9b2f76bd732da4c13b6d4c5716be57a67c3197fad214d04d324d3f39500726754deb0fdde42fb2b5f04407932b3ea63a5dfb5e9588144ea801572efa59aecb5
+DIST qtxdg-tools-4.0.0.tar.xz 16760 BLAKE2B 8e85e4de4c3cdf100de294582cfa9f4d3d0b120bee0ff7a907a308a95d45a1db4a9846899373e13a63e1b8049690e34439ce91d34b6b2964f972c3a5a91641ec SHA512 0d3e3a4afa5a4a0a63b4e9c489b4b20688b5c6c79f6460d9d15dc519bdb911b14f4307e50cd236c20ab939c517eed2ba284295d4f05deb764facda4acad8f4d8
EBUILD qtxdg-tools-3.11.0.ebuild 600 BLAKE2B 8a66a2f000e598909459f5756926bd4d113fb2849c6498607e9576d2af102639d1c45d526090c9612bbc3730d8424f6c32f0cd15cf86c49a4ff23a081a1f17f7 SHA512 de016014c38a326121630d1ac16db6a0a0cc2792cb3d353218a3ccd8caa88bf04ee505f89c0cdc20c0ea73678c3b0d320d1e0d9d7d79c6d9366dd60f9cd74bef
EBUILD qtxdg-tools-3.12.0.ebuild 600 BLAKE2B d37c3a832ae5016fb5f505771d217c51e715aa674c7c5d9fb5fbad7c9b6134f485bc7940aac47d6e1dcf6881de8ed85ca21f4b05e87275603833d59fa6aaa754 SHA512 af91707372394a4fb1b21fdb600ec13395e5d15d569b71e96dac18a61e536cc326eb52de3cffda05a7688e004697aed4c9c58f68f7da115a4bcf12f0aa2afd61
+EBUILD qtxdg-tools-4.0.0.ebuild 561 BLAKE2B 13915f9b4312f48b881bed35fdda47d5f21169f9e9a11a9735406408cb5bf0f5bbfc6d1c1ec6d4930d5f6478fe38ffe9dde0c66c9b84e1e74976361046a1d775 SHA512 30573b21b6cd17f46f16790c1a92a4ff667a387cdfd9f911f345a91ed49826d67e2edcf73f5e554cb472d427b6cfa2d24c6c6afc0cb38ead38a2d7e84e1260e1
MISC metadata.xml 318 BLAKE2B 0cfa3589deb6a2af8f05101ae300035d66d7bd7d0523f3196e005c82c1e0bea15d09feb3b44a2c1db94efccf15f13552e05cf1d38c6fbd7b359f75bea573adbf SHA512 321b105744b1138f2d444235800fa9680c11a92e4e22efccd994c9d103365e2ae449f39ac64f213dce2e895e9b8bcd94c311d1e90a4c00e1f4071a0cd8a68c54
diff --git a/app-misc/qtxdg-tools/qtxdg-tools-4.0.0.ebuild b/app-misc/qtxdg-tools/qtxdg-tools-4.0.0.ebuild
new file mode 100644
index 000000000000..7b3875ecf93b
--- /dev/null
+++ b/app-misc/qtxdg-tools/qtxdg-tools-4.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="User Tools from libqtxdg"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
+RDEPEND="
+ >=dev-libs/libqtxdg-4.0.0
+ >=dev-qt/qtbase-6.6:6
+"
+DEPEND="${RDEPEND}"