summaryrefslogtreecommitdiff
path: root/app-misc/qtxdg-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-09 22:33:12 +0000
commit6147e25e3b1f6ce82b661605708d0b8292c03f47 (patch)
treeb8c60917145c0a076da1e88dd73edfaad594d5a6 /app-misc/qtxdg-tools
parent3f5a5d10d87cd7f434c3a4207fc0a7ffc25d9123 (diff)
gentoo auto-resync : 09:11:2023 - 22:33:12
Diffstat (limited to 'app-misc/qtxdg-tools')
-rw-r--r--app-misc/qtxdg-tools/Manifest2
-rw-r--r--app-misc/qtxdg-tools/qtxdg-tools-3.12.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/qtxdg-tools/Manifest b/app-misc/qtxdg-tools/Manifest
index 0f1e08634a7e..49bfb9275ca5 100644
--- a/app-misc/qtxdg-tools/Manifest
+++ b/app-misc/qtxdg-tools/Manifest
@@ -1,3 +1,5 @@
DIST qtxdg-tools-3.11.0.tar.xz 16716 BLAKE2B ef6b88e69b0b4e8896ba37f7b5f663234a5348759d430600396432f4abb52901001c54ec78bd706efa021b51d9ff514457ff8e123d5142a6562cd380dd5a15ee SHA512 da88f36130b7c23d1553bce252ddc783ae30ba91cd55fba065702376f6cc9c0353c0ad4bb099ed1b65964bd9d476ae431bfde46df110bccec832d3f57cbaa7f3
+DIST qtxdg-tools-3.12.0.tar.xz 16740 BLAKE2B 3e716c85d1715b23001d32a301995d77351f6f95ceaa80a0fa6c1ac1713029b8df97324ac550032fe88315b0fc89adc72b705b1580923f5838c48384222f48a4 SHA512 a9b2f76bd732da4c13b6d4c5716be57a67c3197fad214d04d324d3f39500726754deb0fdde42fb2b5f04407932b3ea63a5dfb5e9588144ea801572efa59aecb5
EBUILD qtxdg-tools-3.11.0.ebuild 600 BLAKE2B 8a66a2f000e598909459f5756926bd4d113fb2849c6498607e9576d2af102639d1c45d526090c9612bbc3730d8424f6c32f0cd15cf86c49a4ff23a081a1f17f7 SHA512 de016014c38a326121630d1ac16db6a0a0cc2792cb3d353218a3ccd8caa88bf04ee505f89c0cdc20c0ea73678c3b0d320d1e0d9d7d79c6d9366dd60f9cd74bef
+EBUILD qtxdg-tools-3.12.0.ebuild 603 BLAKE2B 194d6bda808d72224da81a312d1c0ef44d649619b900526894e794bbddec2cc61552b5c22262f0a9da4939d88e6ae2645da50375957182f20203c3d2dcfe7312 SHA512 11ae49afd7e124c26326bdaad966472e8933f7e327540c37f43c75a3875634e23327127adcaa163d0cc21e7fb78cac06986044d4d8437dfc4bd887c2f4e26dda
MISC metadata.xml 318 BLAKE2B 0cfa3589deb6a2af8f05101ae300035d66d7bd7d0523f3196e005c82c1e0bea15d09feb3b44a2c1db94efccf15f13552e05cf1d38c6fbd7b359f75bea573adbf SHA512 321b105744b1138f2d444235800fa9680c11a92e4e22efccd994c9d103365e2ae449f39ac64f213dce2e895e9b8bcd94c311d1e90a4c00e1f4071a0cd8a68c54
diff --git a/app-misc/qtxdg-tools/qtxdg-tools-3.12.0.ebuild b/app-misc/qtxdg-tools/qtxdg-tools-3.12.0.ebuild
new file mode 100644
index 000000000000..6b8b70d34806
--- /dev/null
+++ b/app-misc/qtxdg-tools/qtxdg-tools-3.12.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="User Tools from libqtxdg"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
+RDEPEND="
+ >=dev-libs/libqtxdg-3.12.0
+ >=dev-qt/qtcore-5.15:5
+"
+DEPEND="${RDEPEND}"