summaryrefslogtreecommitdiff
path: root/app-misc/physlock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/physlock
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/physlock')
-rw-r--r--app-misc/physlock/Manifest5
-rw-r--r--app-misc/physlock/metadata.xml18
-rw-r--r--app-misc/physlock/physlock-0.5.ebuild22
-rw-r--r--app-misc/physlock/physlock-11-r1.ebuild27
4 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/physlock/Manifest b/app-misc/physlock/Manifest
new file mode 100644
index 000000000000..88ff6cbba328
--- /dev/null
+++ b/app-misc/physlock/Manifest
@@ -0,0 +1,5 @@
+DIST physlock-0.5.tar.gz 13547 BLAKE2B f45a69476beff2c86787efc6b41c1dc330284a4c212927b45938d0bc531cef53ff01845277dc273bb826533c46b689667162f25936bfd35fe670b5f3c2642627 SHA512 0e22d2c1093556e2ca52da4ee36e53a7eebf9c2cf8e10592c95971aa3479c3ee1a31b9d71e52fca715a483f22740f6cf9a3c167fb61e4c6034a2ecf900fd5f9d
+DIST physlock-11.tar.gz 13791 BLAKE2B 73ba9ad238a4566156144a7107018689996691d1a24bab44e9575067efe072cfb6181b409a81ebcad03d42a48ea94fe32fc738f2d730cb1fd0137b2455a5a74b SHA512 d3badf5c99e4e3e16f4e7ec5c59ee8320c845f1b180463900d816206362ce1aa8652f2489453ad5e190cceee2ed61a90acc52e25bb6b4c4a9dc8c4ebd3054938
+EBUILD physlock-0.5.ebuild 471 BLAKE2B 70adcf4d2e320869458473b88dfdd8a858f2aa8007654c10817285386b0b1311725c20605b8d59d9345d86acdf2338eb426a59dd423b824c27c5551501719dcd SHA512 743491ca82a6f0495b22c2356f8f27846cd27689f4b2e67473de54aa7551a46c7c1865d7a6b2a0c59bbf329f9323700973089403aabdf049aa3d0f1242c07f54
+EBUILD physlock-11-r1.ebuild 553 BLAKE2B 93be1c05c828d028f2176e32fac1723cbd065e6cf25c19c49eb9509bf3794e7310beaaebf0555f9087d818a7e9386a0de8f9bebe715f4a3c9492322a2b2c7080 SHA512 64d965a8fa93986b39ad74e313c4963bcaa342b7ac758532760db10de1375d2886b5f98dd43d19e7912fa6d93b5de8dacfe93e49de913ddcb0fe9e8757b68215
+MISC metadata.xml 757 BLAKE2B 91000aca8e366f965b46d72494b23734db9d5866c41f2f364755b9bf1397ce673ae96a8c182ee732ca3b05fae863cb8caaf61478f708df33ad3fe21e246b4af4 SHA512 34f57b70b867095ad5ddffad1a5a943488699e98495e98631dde72a96fca5260947bcece476e4411d146d6a1f72ed602401455d49343a4fa79faae77b5483625
diff --git a/app-misc/physlock/metadata.xml b/app-misc/physlock/metadata.xml
new file mode 100644
index 000000000000..3a7f9b503b95
--- /dev/null
+++ b/app-misc/physlock/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ Control physical access to a linux computer by locking all of its virtual
+ terminals / consoles.
+
+ physlock is an alternative to vlock, it is equivalent to `vlock -an'. It is
+ written because vlock blocks some linux kernel mechanisms like hibernate and
+ suspend and can therefore only be used with some limitations. physlock is
+ designed to be more lightweight, it does not have a plugin interface and it is
+ not started using a shell script wrapper.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">muennich/physlock</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/physlock/physlock-0.5.ebuild b/app-misc/physlock/physlock-0.5.ebuild
new file mode 100644
index 000000000000..f306ba46c194
--- /dev/null
+++ b/app-misc/physlock/physlock-0.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="lightweight Linux console locking tool"
+HOMEPAGE="https://github.com/muennich/physlock"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}
diff --git a/app-misc/physlock/physlock-11-r1.ebuild b/app-misc/physlock/physlock-11-r1.ebuild
new file mode 100644
index 000000000000..761fce5332c0
--- /dev/null
+++ b/app-misc/physlock/physlock-11-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="lightweight Linux console locking tool"
+HOMEPAGE="https://github.com/muennich/physlock"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="virtual/pam"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dosym login /etc/pam.d/${PN}
+}