summaryrefslogtreecommitdiff
path: root/app-misc/pax-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /app-misc/pax-utils
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/Manifest2
-rw-r--r--app-misc/pax-utils/pax-utils-1.2.8.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/app-misc/pax-utils/Manifest b/app-misc/pax-utils/Manifest
index bd07f9628bb6..8525589c92e4 100644
--- a/app-misc/pax-utils/Manifest
+++ b/app-misc/pax-utils/Manifest
@@ -1,3 +1,5 @@
DIST pax-utils-1.2.6.tar.xz 680696 BLAKE2B b271e19ed5ec1024d7c6e5723c12464c6ab07646dfbfd4738bfe0250629205051642421425d7c7c5f540b1ac3d100c13d1beca398d9766f7f477830ab128eef2 SHA512 59fe16c5573414aa2952a99c5b85c16cf10dbbee76943f263d31d5b1aa8818a9b00fa78c8b6dadbe02216de54fc32b26d80303a17e2d854de6bb9dd8b431f617
+DIST pax-utils-1.2.8.tar.xz 704804 BLAKE2B b64b50f985320618e10528aaddbeee9a2c86b05724d8564342fc78fd8bd31a84f3cfe5e6051b3b8a1a882bb0b3da586ca351b6fdda0fd6168930e8e4a44806cb SHA512 c211defb72921a6dfa950173bef7ef6bc5ac059dbb394a82d2b2455d082843fc7722a6819f37aa39033bd37a5a77880f193f8be550020320e87ce5becfa6e5bf
EBUILD pax-utils-1.2.6.ebuild 1903 BLAKE2B 308656bc3fbf8c597c984dd61c86ec4fcf5084b75c4a83e417ccdc49fae8c49b65b0195ad0156e009fe8e41d6ae6a5555df8781b55c4a8288b3abe01fa4f2d44 SHA512 b4a3b8872fc4e6f23ba6a22fb77bb0f73624bd76450ee8be8823bd9b7b487266b407cc7cbb5526a609fb8b0c8df5a8f9307ead8f0af741a49ea9f5997825a9dc
+EBUILD pax-utils-1.2.8.ebuild 1912 BLAKE2B 6b93612f1ce8aa8e109fc0ec667592d0b5eccfdf49db0be3aa84680187ad62b19ce5de2866d49bc7fdd9b21eaacf02359beea29aa14e59a4eaf8971cd0e228a4 SHA512 ba8f8de048d29b678ca5efb18ea9880781c26cbcdf799a7b3cbc406973f296311ca308520a3e947d461e9e4cb63d9160d75c68e0b2657f6c96a7e2b9294ff5de
MISC metadata.xml 795 BLAKE2B 410a2dbab6104e5da8b29d92f288ac82619bea027e1e452428c9bb993d8b34475a2ce6d7d0ed8c40244f0ac31b619cc7a221c3545b46b8029284adbcbd45d9e5 SHA512 97e8fafd52f62a3db3d28a61f55895ecf667592516be68977599dd82d10c2107eb325218ccfc102d51cf8ce453c3f64e8ab4b82b25a5298bcf3ff0e33cdf40f3
diff --git a/app-misc/pax-utils/pax-utils-1.2.8.ebuild b/app-misc/pax-utils/pax-utils-1.2.8.ebuild
new file mode 100644
index 000000000000..97ad76dbc3c2
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.2.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit eutils python-single-r1 toolchain-funcs
+
+DESCRIPTION="ELF utils that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps debug kernel_linux python seccomp"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+ seccomp? ( sys-libs/libseccomp )
+"
+# >=linux-headers-4.11 to pick linux headers with statx, bug #737094
+DEPEND="
+ ${RDEPEND}
+ kernel_linux? ( !prefix-guest? ( >=sys-kernel/linux-headers-4.11 ) )
+"
+BDEPEND="
+ caps? ( virtual/pkgconfig )
+ seccomp? ( virtual/pkgconfig )
+"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_DEBUG=$(usex debug) \
+ USE_PYTHON=$(usex python) \
+ USE_SECCOMP=$(usex seccomp) \
+ "$@"
+}
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux ||
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
+ else
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+
+ use python && python_fix_shebang "${ED}"/usr/bin/lddtree
+}