summaryrefslogtreecommitdiff
path: root/app-misc/openrgb/openrgb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-27 02:53:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-27 02:53:16 +0100
commitf1aa825b8483db57bf28d0772acfa10aeebe83c3 (patch)
treed56ade77461ea49cbbb4943bd2e100eb6b97bb76 /app-misc/openrgb/openrgb-9999.ebuild
parent0e83ee97d831abe38c8e764fb9bbfef9de04daf2 (diff)
gentoo auto-resync : 27:08:2022 - 02:53:16
Diffstat (limited to 'app-misc/openrgb/openrgb-9999.ebuild')
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index f9e079015112..44c450e3c857 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils
+inherit flag-o-matic qmake-utils udev
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -41,7 +41,7 @@ BDEPEND="
PATCHES+=(
"${FILESDIR}"/OpenRGB-0.7-plugins.patch
- "${FILESDIR}"/OpenRGB-0.7-udev.patch
+ "${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
)
src_prepare() {
@@ -64,8 +64,17 @@ src_install() {
emake INSTALL_ROOT="${ED}" install
dodoc README.md OpenRGB.patch
+ udev_dorules 60-openrgb.rules
# This is for plugins. Upstream doesn't install any headers at all.
insinto /usr/include/OpenRGB
find . -name '*.h' -exec cp --parents '{}' "${ED}/usr/include/OpenRGB/" ';' || die
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}