summaryrefslogtreecommitdiff
path: root/app-misc/openrgb/openrgb-0.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 10:00:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 10:00:13 +0000
commit73ef00f9e2b100c7d0fedede11300940cc26670a (patch)
tree19d1f10cdd98aec4743c36942242eac9f318641d /app-misc/openrgb/openrgb-0.7-r1.ebuild
parent063e5b486db858a2b1ecec798af89f5484d475bd (diff)
gentoo auto-resync : 27:02:2023 - 10:00:13
Diffstat (limited to 'app-misc/openrgb/openrgb-0.7-r1.ebuild')
-rw-r--r--app-misc/openrgb/openrgb-0.7-r1.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/app-misc/openrgb/openrgb-0.7-r1.ebuild b/app-misc/openrgb/openrgb-0.7-r1.ebuild
deleted file mode 100644
index fc7b38dbf97b..000000000000
--- a/app-misc/openrgb/openrgb-0.7-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic qmake-utils udev
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
-else
- SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
- S="${WORKDIR}/OpenRGB-release_${PV}"
- KEYWORDS="amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
-fi
-
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
-HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
-LICENSE="GPL-2"
-# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
-SLOT="0/2"
-
-RDEPEND="
- dev-libs/hidapi
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- net-libs/mbedtls:=
- virtual/libusb:1
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/nlohmann_json
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES+=(
- "${FILESDIR}"/OpenRGB-0.7-plugins.patch
- "${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
- "${FILESDIR}"/OpenRGB-0.7-json.patch
-)
-
-src_prepare() {
- default
- rm -r dependencies/{hidapi,libusb,json,mbedtls}* || die
-}
-
-src_configure() {
- # Some plugins require symbols defined in the main binary.
- # The official build system bundles OpenRGB as a submodule instead, and
- # compiles the .cpp file again.
- append-ldflags -Wl,--export-dynamic
-
- eqmake5 \
- INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
- DEFINES+="GENTOO_PLUGINS_DIR=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
-}
-
-src_install() {
- emake INSTALL_ROOT="${ED}" install
-
- dodoc README.md OpenRGB.patch
- udev_dorules 60-openrgb.rules
-
- # This is for plugins. Upstream doesn't install any headers at all.
- insinto /usr/include/OpenRGB
- find . -name '*.h' -exec cp --parents '{}' "${ED}/usr/include/OpenRGB/" ';' || die
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}