summaryrefslogtreecommitdiff
path: root/app-misc/openrgb-plugin-visualmap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /app-misc/openrgb-plugin-visualmap
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'app-misc/openrgb-plugin-visualmap')
-rw-r--r--app-misc/openrgb-plugin-visualmap/Manifest3
-rw-r--r--app-misc/openrgb-plugin-visualmap/metadata.xml15
-rw-r--r--app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0_p20210614.ebuild47
3 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-visualmap/Manifest b/app-misc/openrgb-plugin-visualmap/Manifest
new file mode 100644
index 000000000000..da5619d59c7b
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/Manifest
@@ -0,0 +1,3 @@
+DIST OpenRGBVisualMapPlugin-b603bb994719c765cc52c116c6f9f3983fc2a7b2.tar.bz2 45381 BLAKE2B e289f952a8f6553ff81a557753cbb94fb56111a6724f3141fc44a2f1abe9fa3d8e8b4eb769b54adfcb8ee6580d26378ca0b15fd83c14eb669e4682dad07729b8 SHA512 aab553dff55bc4d6990657ad9f29dbbe5ab78dfb532dba50923b32c2bb86ced8d37fc1190dca1b59f420aba7f0db81fbd0d35d49e499e19b9efa4638269a784d
+EBUILD openrgb-plugin-visualmap-0_p20210614.ebuild 1272 BLAKE2B 7acd90ea08a8682273095a684e261de453404939d6d1e8d14493cf06049eb0534c33cd3bd6b2235afb966321f08a0e1f9c6d49dfacea3a22193a15a95a546a5d SHA512 0608740bea699c2368b6485fcb7f6cd666b8244abe6930bca00551b38aa1abfe3a0b83eaa84dad929f884594a9a47fe92e822477720eaeaecfbbc7f3d260f30b
+MISC metadata.xml 483 BLAKE2B 8a331ab87feb1fe11fe4a5d9e0d7657685d858182c847e3ef3d647f2b0f4f0f31de36c4fba307a1a9ca09ba82fc8aba9a6a887fe2669b453fa7b96e82d54ec57 SHA512 304f23af3f70c7ae7c7221bf53cc991e160711bc7160d7d6082388b457cf88c06851b66963537580fd15c60d63cf0787722b1f63f16c4679d47fc8ef173469f2
diff --git a/app-misc/openrgb-plugin-visualmap/metadata.xml b/app-misc/openrgb-plugin-visualmap/metadata.xml
new file mode 100644
index 000000000000..6a2173ad1876
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">OpenRGBDevelopers/OpenRGBEffectsPlugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0_p20210614.ebuild b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0_p20210614.ebuild
new file mode 100644
index 000000000000..c75698693526
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0_p20210614.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+MY_GIT_COMMIT="b603bb994719c765cc52c116c6f9f3983fc2a7b2"
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/${MY_GIT_COMMIT}/OpenRGBVisualMapPlugin-${MY_GIT_COMMIT}.tar.bz2"
+S="${WORKDIR}/OpenRGBVisualMapPlugin-${MY_GIT_COMMIT}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBEffectsPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.6-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ sed -i -e '/RGBController.cpp/d' OpenRGBVisualMapPlugin.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB/RGBController" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB/i2c_smbus" \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/OpenRGB/net_port"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBVisualMapPlugin.so.1.0.0
+}