summaryrefslogtreecommitdiff
path: root/app-misc/openrgb-plugin-skin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
commit8973f70e9a2ae4ea8a324e607ea1e8b96c7ff384 (patch)
treebbe587aee6b255e6cc44d4fd753d1cb9dbd1cfce /app-misc/openrgb-plugin-skin
parentf29a41111b3a606f5d95049b1ba92daabbc68cc0 (diff)
gentoo auto-resync : 05:01:2023 - 18:09:32
Diffstat (limited to 'app-misc/openrgb-plugin-skin')
-rw-r--r--app-misc/openrgb-plugin-skin/Manifest2
-rw-r--r--app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-skin/Manifest b/app-misc/openrgb-plugin-skin/Manifest
index 7d9cb1bb8993..2a96b675bda6 100644
--- a/app-misc/openrgb-plugin-skin/Manifest
+++ b/app-misc/openrgb-plugin-skin/Manifest
@@ -1,3 +1,5 @@
+DIST OpenRGBSkinPlugin-release_0.8.tar.bz2 22711 BLAKE2B 25325c6be5cf619940e79e4f431871478e3026188d7aba4b8220a99afda8f75d18ffeafa0f905110d4ce44f5d7e28208f3d7b358cfadfcd4719a22f1ef5cf70d SHA512 89b9a4bcda4600ea7dbd05972bba7c5f8d917606b3def4971e6ccff84d8510ca420747dd85d3395bfea29e62adc775b592f9cbe20a6966776a46e15593f2cf59
DIST openrgbskinplugin-ebb80f7bd0e1efaa995f60454f3c049a4607bc3b.tar.bz2 22843 BLAKE2B 30c88b143b3df829c543744b20424df24bde9dda10f770fb78d653609111801a4d1d3fe16ed3e3c15ad953f41113db5d4da40bc66f7ec57418b2e934cd9a2e32 SHA512 a70c0157072b6b638a5a4f3f48f41c73f422d0ac356174479901cd3d088faf6fe96e594b2a39b15de305e0355fd0d252dafc4a30b9216d57058ad2cde7f5a3e3
+EBUILD openrgb-plugin-skin-0.8.ebuild 966 BLAKE2B 8263ada754a312c3fb34a9510b9630ec4b3de2eadb7baf78b623703e7e4ae64c27e896c6b08ec2b7607341fa67eae1a725404698d2fc8c3efc6a08806435e2c0 SHA512 d616850834306b32b9aacd1e6c5755f5adc0c934a29e5c2c7af31ff7e306ad38d95f06cbd21589ed4996b6da014d3b00be7955e59d6ae686258d9a8fd95e8886
EBUILD openrgb-plugin-skin-0_p20211230.ebuild 1031 BLAKE2B 159cfc98558763303f0709bfa2b86fafe1571edb6aac806c37a76e711220e8b3111a51caea1e76bded0dc6bf97401cf63f8edc14fde78fd50e60f63027383514 SHA512 089258850a1b9b4d6d595358060350a76fc15e7dc8473a587190b1a432d38bb6dc071f28784f9ac7eb5c54ba55f347d76b6e6a11c57368718206080dc8aca124
MISC metadata.xml 481 BLAKE2B f05f1f16d6180b976f0daa79964c7abe5f9f1caee3aa25c1b328916d810438b7e76fd54297412f02c6fd172d6ca754872cd7d28349c328c8ef9cc8af7069a4be SHA512 9a6815da58c1b372a4af82f96484625334c2977a416e902b824d2be17bc7624cf9d1d69f0bc25ce85b833133b81c10e9257f30c825fdeeb230c7ce8772cf4bfd
diff --git a/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild
new file mode 100644
index 000000000000..8a3da828c824
--- /dev/null
+++ b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBSkinPlugin/-/archive/release_${PV}/OpenRGBSkinPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBSkinPlugin-release_${PV}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB that allows you to customize the look and feel of OpenRGB"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBSkinPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.8:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBSkinPlugin.so.1.0.0
+}