summaryrefslogtreecommitdiff
path: root/app-misc/oneko/oneko-1.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/oneko/oneko-1.2-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/oneko/oneko-1.2-r2.ebuild')
-rw-r--r--app-misc/oneko/oneko-1.2-r2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/oneko/oneko-1.2-r2.ebuild b/app-misc/oneko/oneko-1.2-r2.ebuild
new file mode 100644
index 000000000000..9866e7ac2964
--- /dev/null
+++ b/app-misc/oneko/oneko-1.2-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A cat, dog and others which chase the mouse or windows around the screen"
+HOMEPAGE="http://www.daidouji.com/oneko/"
+SRC_URI="http://www.daidouji.com/oneko/distfiles/${P}.sakura.5.tar.gz
+ mirror://gentoo/${P}-cat.png
+ mirror://gentoo/${P}-dog.png
+ mirror://gentoo/${P}-sakura-nobsd.patch.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-base/xorg-proto
+ x11-misc/gccmakedep
+ x11-misc/imake
+"
+
+S=${WORKDIR}/oneko-${PV}.sakura.5
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/${P}-sakura-nobsd.patch \
+ "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ dobin oneko
+ newman oneko._man oneko.1x
+ dodoc README README-NEW README-SUPP
+ newicon "${DISTDIR}/${P}-cat.png" "cat.png"
+ newicon "${DISTDIR}/${P}-dog.png" "dog.png"
+ make_desktop_entry "oneko" "oneko (cat)" "cat" "Game;Amusement"
+ make_desktop_entry "oneko -dog" "oneko (dog)" "dog" "Game;Amusement"
+ make_desktop_entry "killall -TERM oneko" "oneko kill" "" "Game;Amusement"
+}
+
+pkg_postinst() {
+ elog "To kill oneko, type the following in a terminal:"
+ elog ""
+ elog "killall oneko"
+ elog ""
+ elog "If your mouse cursor changes to the default black cross"
+ elog "after running ${PN}, you should emerge x11-apps/xsetroot"
+ elog "and run:"
+ elog ""
+ elog "xsetroot -cursor_name left_ptr"
+ elog ""
+}