summaryrefslogtreecommitdiff
path: root/app-misc/ola
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 03:59:18 +0000
commit063e5b486db858a2b1ecec798af89f5484d475bd (patch)
tree490932df05aadb9cbb3611e63a31507953ab5c91 /app-misc/ola
parenta0953f7ac639d8e180f62ab3364ccf9af71f783d (diff)
gentoo auto-resync : 27:02:2023 - 03:59:17
Diffstat (limited to 'app-misc/ola')
-rw-r--r--app-misc/ola/Manifest2
-rw-r--r--app-misc/ola/ola-0.10.9.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/app-misc/ola/Manifest b/app-misc/ola/Manifest
index 342f22595221..163ca9e8b563 100644
--- a/app-misc/ola/Manifest
+++ b/app-misc/ola/Manifest
@@ -1,4 +1,6 @@
AUX ola-0.10.8-python_version_check.patch 953 BLAKE2B 6cc60d99a8f6c709e335c291fce0a887eb9aad94325887f8561699b4e1a8310ae82b15f9c21da530cc860375cf1c2fa6965c090bd4d57b09cf7ba0168ecc30c0 SHA512 fc979e59bc3ca60a52df1e8dec115477b26de91cd18bc762d27f5f8e2859bfb5c82889975523cc15f722932fab525ca19b39b56f4b03728310e5fda7dfefe6be
DIST ola-0.10.8.tar.gz 2552023 BLAKE2B b4fa7e36e2b907e8f0ea16ef089607fc223afc543752a03740fd1d525062ea676d2f392bb623804543827d6f5ac6078c469a3edcb4321bca9a454b1c219f9c89 SHA512 78ef8cc7f8e8d0b1d15bbb305d99a589fce82e07e89ca3bf2466bef8cdc1b18f590fc8dcbf29fc5af2349e0721c832f525fd665d62498907554ee742d79cd3d2
+DIST ola-0.10.9.tar.gz 2578760 BLAKE2B 8cace370b21788d0fe65e56d33fdc9436a5103837d370e3e7e07b43318d4ec3b29536b55c4b117f515a4698ebab88f58718759a0cf9a00f79d0b839e7a79d581 SHA512 e8e2f4249d6e1f63f6c36ae548d9e3a82080f0da82829f923ba6b4d63685fb89f9baccf4588fd6fcbf756708d91e27d022c0d623e7c03c84ec058e7dc7c46bdf
EBUILD ola-0.10.8.ebuild 2430 BLAKE2B add36a82646cd0af033362efc14d0094ae293b8226a203c8f57eb5973034273bd3844d0b842681e947f4da9d7735859c86ccd1b941671cd39124583d8622c80a SHA512 9117910d63f198cda703fb35f5056ce197c0a610c7207e13f10fef5783ed988edacac9d8c30321156b593212537c55e910f8432bc1f254726667505ffb877436
+EBUILD ola-0.10.9.ebuild 2362 BLAKE2B a450424f36da44e80cf1649dcd970579515181868f853d34f9e9aa739e8d5cba8cb400055248886751fd2911747727704b413c11698d74cd5b79f3295944af4f SHA512 309d9acdb834e88d877f381cef6c1cb8ab9b366c031f63a3d5b8da076bbe7022020a9fa0f2a5e883f083459c07ccf2e24ffbadea0b31dac3ed3cd782707eea5f
MISC metadata.xml 1012 BLAKE2B 181177e538c6cdc37b3ba630b3bd3cffd1701e4f674cd51c6032c3b0367c11a0090482055328961e150203f47a1662597e2d0164c65c12662ce3ae2407db5a98 SHA512 01e6e96741b65a895229e7626e6fbfc51132d7b841c597933ea7055c302369264d014da1ff9c9bbad014c1cb812bb43d120a1d40c473c40eef6353ed4bfafc11
diff --git a/app-misc/ola/ola-0.10.9.ebuild b/app-misc/ola/ola-0.10.9.ebuild
new file mode 100644
index 000000000000..5cdbca6899a9
--- /dev/null
+++ b/app-misc/ola/ola-0.10.9.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Open Lighting Architecture, a framework for lighting control information"
+HOMEPAGE="https://www.openlighting.org/ola/"
+SRC_URI="https://github.com/OpenLightingProject/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples ftdi http osc python rdm-tests tcmalloc test usb zeroconf"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ rdm-tests? ( python )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/protobuf:=
+ sys-apps/util-linux
+ sys-libs/ncurses
+ ftdi? ( dev-embedded/libftdi:1 )
+ http? ( net-libs/libmicrohttpd:= )
+ osc? ( media-libs/liblo )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ ')
+ )
+ rdm-tests? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+ tcmalloc? ( dev-util/google-perftools:= )
+ usb? ( virtual/libusb:1 )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+BDEPEND="sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ test? (
+ dev-util/cppunit
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ ')
+ )
+ )"
+
+src_prepare() {
+ default
+ # Upstream recommends doing this even for tarball builds
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatal-warnings
+ --with-uucp-lock="/run"
+ $(use_enable doc doxygen-doc)
+ $(use_enable doc doxygen-dot)
+ $(use_enable examples)
+ $(use_enable ftdi libftdi)
+ $(use_enable http)
+ $(use_enable osc)
+ $(use_enable python python-libs)
+ $(use_enable rdm-tests)
+ $(use_enable tcmalloc)
+ $(use_enable test unittests)
+ $(use_enable usb libusb)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ use doc && emake doxygen-doc
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use doc; then
+ dodoc -r html
+ docompress -x /usr/share/doc/${PF}/html
+ fi
+
+ if use examples && use python; then
+ docinto examples
+ python_fix_shebang python/examples/*.py
+ dodoc python/examples/*.py
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}