summaryrefslogtreecommitdiff
path: root/app-misc/nut/nut-20.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/nut/nut-20.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/nut/nut-20.1.ebuild')
-rw-r--r--app-misc/nut/nut-20.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/nut/nut-20.1.ebuild b/app-misc/nut/nut-20.1.ebuild
new file mode 100644
index 000000000000..3c028aa44a87
--- /dev/null
+++ b/app-misc/nut/nut-20.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Record what you eat and analyze your nutrient levels"
+HOMEPAGE="http://nut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ppc x86"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ OPT="${CFLAGS}" FOODDIR=\\\"/usr/share/nut\\\" \
+ nut
+}
+
+src_install() {
+ insinto /usr/share/nut
+ doins raw.data/*
+
+ dobin nut
+ doman nut.1
+}