summaryrefslogtreecommitdiff
path: root/app-misc/neofetch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-misc/neofetch
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-misc/neofetch')
-rw-r--r--app-misc/neofetch/Manifest3
-rw-r--r--app-misc/neofetch/neofetch-7.1.0-r1.ebuild42
-rw-r--r--app-misc/neofetch/neofetch-9999.ebuild21
3 files changed, 53 insertions, 13 deletions
diff --git a/app-misc/neofetch/Manifest b/app-misc/neofetch/Manifest
index 969ebddc9858..5adcd2fbd57d 100644
--- a/app-misc/neofetch/Manifest
+++ b/app-misc/neofetch/Manifest
@@ -1,4 +1,5 @@
DIST neofetch-7.1.0.tar.gz 95400 BLAKE2B 32368d461835d95ba8203c560b2f6733594966cbaf809d877a46c08675284288565e3a21b14d94900dd66b778dc975339196f182732e2cd8bc1ccc9e6da6253e SHA512 fe1013fb54585c15ba556054478a2c8c503120387e81bd16bfdfbb6f3a188ed4124585540abf43da9209cbbe0d7fb90d50914cd6620137d00f013cfb6954a042
+EBUILD neofetch-7.1.0-r1.ebuild 1147 BLAKE2B 12a4fe99b0c45f980d0452a4b96288a8543beb03f94eb81195dd11a1b87129506f7d9bf5a6a54380d4b6289988e7f2098680804924fb9cf32a7386fe1e6efaa7 SHA512 753c3e6ebae6688c78246d2276dfadd37baeb004763e5d9d26cd04dcafa1b77f48304456df92e3ca78eefb0d419bde969eb438d1bd2d80674ed5d8504bb3a7ed
EBUILD neofetch-7.1.0.ebuild 937 BLAKE2B 72424ef48458c2c4c0a70900f42f597ebaf0ec659b3fadc9e860262b336d066786b078412c363394c674250d52fcb2ab267c665d2778b98cea96a1baf759134c SHA512 568336106a81b75f35e657c7f494e6b1b7683dbba29085bc28c0e7b441d288c5a013ba3c6ebd1ad62b3862ec8ad835b6fcea07eb0dcd590b907c38f4427d79aa
-EBUILD neofetch-9999.ebuild 939 BLAKE2B a9e42345b9a4a07ada01f8f5a3b38749c58673059fc256506cb73334e632237e7824caf3b33c5b4d2b1aecfa78bfaf5f010b6babd5efd3ebef3ebc6ba7cb842e SHA512 c4d7d5aa941269102ef16f071a0ce92717f3975d41d89adf2a986d47e848de5fe912cdd1c3739bc2325b2d60d86ec8c9d2eacd53d687a1baed5b4950676e31a2
+EBUILD neofetch-9999.ebuild 1147 BLAKE2B 12a4fe99b0c45f980d0452a4b96288a8543beb03f94eb81195dd11a1b87129506f7d9bf5a6a54380d4b6289988e7f2098680804924fb9cf32a7386fe1e6efaa7 SHA512 753c3e6ebae6688c78246d2276dfadd37baeb004763e5d9d26cd04dcafa1b77f48304456df92e3ca78eefb0d419bde969eb438d1bd2d80674ed5d8504bb3a7ed
MISC metadata.xml 862 BLAKE2B 962450327b7dcc5718d64b88ce3d8fd1b68a276d17d347fb7e7729bd8181b4c3784b2d8444d9afaec4c64082ad74cac77ac381976b404b5350c4013b041c60db SHA512 ba333d9291f5d56e1d942eb40278c13d2bf2cad13c0eeae0fe1d83cf516810af7086b9713aca2ed3a580bf9ac33b328bece3c52a1bcce1e197430ece8549e94b
diff --git a/app-misc/neofetch/neofetch-7.1.0-r1.ebuild b/app-misc/neofetch/neofetch-7.1.0-r1.ebuild
new file mode 100644
index 000000000000..b0c0a070de9b
--- /dev/null
+++ b/app-misc/neofetch/neofetch-7.1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature prefix
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~ppc64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
+fi
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+
+src_prepare() {
+ if use prefix; then
+ # bug #693526
+ hprefixify neofetch
+ sed -e "/has emerge/s:\${br_prefix}:${EPREFIX}:" -i neofetch \
+ || die "Failed to adjust for Prefix"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+}
diff --git a/app-misc/neofetch/neofetch-9999.ebuild b/app-misc/neofetch/neofetch-9999.ebuild
index b5f654d39b3b..b0c0a070de9b 100644
--- a/app-misc/neofetch/neofetch-9999.ebuild
+++ b/app-misc/neofetch/neofetch-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit prefix
+inherit optfeature prefix
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
@@ -17,17 +17,6 @@ DESCRIPTION="Simple information system script"
HOMEPAGE="https://github.com/dylanaraps/neofetch"
LICENSE="MIT-with-advertising"
SLOT="0"
-IUSE="X"
-
-RDEPEND="sys-apps/pciutils
- X? (
- media-gfx/imagemagick
- media-libs/imlib2
- www-client/w3m[imlib]
- x11-apps/xprop
- x11-apps/xrandr
- x11-apps/xwininfo
- )"
src_prepare() {
if use prefix; then
@@ -43,3 +32,11 @@ src_prepare() {
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+}