summaryrefslogtreecommitdiff
path: root/app-misc/mepl/mepl-0.45-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/mepl/mepl-0.45-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/mepl/mepl-0.45-r1.ebuild')
-rw-r--r--app-misc/mepl/mepl-0.45-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/mepl/mepl-0.45-r1.ebuild b/app-misc/mepl/mepl-0.45-r1.ebuild
new file mode 100644
index 000000000000..65c2b5cb7bf8
--- /dev/null
+++ b/app-misc/mepl/mepl-0.45-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Self-employed-mode software for 3COM/USR message modems"
+HOMEPAGE="http://www.hof-berlin.de/mepl/"
+SRC_URI="http://www.hof-berlin.de/mepl/mepl${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${PN}${PV}"
+
+PATCHES=( "${FILESDIR}/${P}-gcc433.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DMEPLCONFIG=\\\"/etc/mepl.conf\\\" ${LDFLAGS}" en
+}
+
+src_install() {
+ dobin "${PN}" "${PN}mail"
+ insinto /etc
+ doins "${PN}.conf"
+ newman "${PN}.en" "${PN}.7"
+}