summaryrefslogtreecommitdiff
path: root/app-misc/mc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /app-misc/mc
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/Manifest2
-rw-r--r--app-misc/mc/mc-4.8.23.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/mc/Manifest b/app-misc/mc/Manifest
index 5e355b44a066..19ed48635ad8 100644
--- a/app-misc/mc/Manifest
+++ b/app-misc/mc/Manifest
@@ -1,4 +1,6 @@
DIST mc-4.8.22.tar.xz 2538524 BLAKE2B f7839177dfb02d5b56d6a4ae1f045f7bc501b70fc845efaa6d45ef8e432ec680e51e4530aa5aa25c33ad339171d1ff435f6a1c5dbc5ac150053c64101b7a5c30 SHA512 834d467a4561fe4361bbde61be2c9ded95ade2a89855d953f58b7bfeb21297a3d6ebf674e72ac665b1794e0cbc8da752bc14fb37b129ff870856b339091f6bed
+DIST mc-4.8.23.tar.xz 2552944 BLAKE2B f246f30d852f93ac96f81ec7a933a1bcd86ff3bfa040a0fa1cb32c14d781f77df34452e4dd94f0846e379d91a648cd417241e4660930a9c90defe58cb19d1cee SHA512 e51c7f926d296280a57a8ecb5f4b296a850022b7ab9beaba89f5cb7554d8fc3e13c73b8571f78c3162ee85df88f7f46d07c9c893156cda4d1377a01071cdd1c6
EBUILD mc-4.8.22.ebuild 2856 BLAKE2B 4690f984d23c2397b1934708b3fe03b357e6422516bc59ed50ff9e7a32988e6019ab69cecd7618ef4e60725f30367e76da3a249b4d5b04b7bec4f0346aedb977 SHA512 0976c89075f0dd7cb3028b2855824b441a74cdd981064a892d2446347484e9fbbba236705ee99f7b2b7163e6dd0769d902da85dfb0ae05a66667a82c9c6e911d
+EBUILD mc-4.8.23.ebuild 2866 BLAKE2B 05678e4bd3e32278f6a09c65b028fa731997481af928798edc09dd780e7c373d04a92d7dd9a2ce5c6a999ebb11f15a3b5f63b20de31ae11a043f9f01f1491232 SHA512 630ff657da56cde5e2bcfdd3c26b24416515087f4f61246f7d6bfd384a8f8d479ab2d163bb66173d31db03c7bad0be18d9f1a1c1d0e4ddc1b6b4719aef84a579
EBUILD mc-9999.ebuild 3113 BLAKE2B ec6b556a149078643e7dfd5a3fbd5bc43c174b1cfb5e2d05d578c7ac9dfe084347ee262100d5b2c6d5fe9bbc3feaed504e93252bbc01f8431d49d1794eb63425 SHA512 8693c20e841d2b3f83073a444cca6e8013046e1f7ac7007f12d11a384e2db691ac06930f782f3585e9d7441a964967b143b3bee740c6287d64ac2e04f6277c5e
MISC metadata.xml 916 BLAKE2B ebd4f95dda619c29e09fdb42087a52a5c1ff2dfa0d5a7ed5bea12776734247bb04d8e19333be9ea45345a3e520ac7504ea490501767111feacf9f933caf3661a SHA512 e8b3384dc473a15550dca185fce45d12019939170155665ce26e6ce2e0abf8e387501e6429c30eefe0e5f15a1b0b1b49d12e2cf5305ef6c08415bbddb48db9ec
diff --git a/app-misc/mc/mc-4.8.23.ebuild b/app-misc/mc/mc-4.8.23.ebuild
new file mode 100644
index 000000000000..3d20a797b3a8
--- /dev/null
+++ b/app-misc/mc/mc-4.8.23.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="https://www.midnight-commander.org"
+SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm nls samba sftp +slang spell test unicode X +xdg"
+
+REQUIRED_USE="spell? ( edit )"
+
+RDEPEND=">=dev-libs/glib-2.26.0:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh2 )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses:0=[unicode?] )
+ spell? ( app-text/aspell )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )
+ "
+
+S=${WORKDIR}/${MY_P}
+
+pkg_pretend() {
+ if use slang && use unicode ; then
+ ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
+ fi
+}
+
+src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ local myeconfargs=(
+ --disable-dependency-tracking
+ --disable-silent-rules
+ --enable-charset
+ --enable-vfs
+ --with-homedir=$(usex xdg 'XDG' '.mc')
+ --with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w' '')")
+ $(use_enable kernel_linux vfs-undelfs)
+ # Today mclib does not expose any headers and is linked to
+ # single 'mc' binary. Thus there is no advantage of having
+ # a library. Let's avoid shared library altogether
+ # as it also conflicts with sci-libs/mc: bug #685938
+ --disable-mclib
+ $(use_enable nls)
+ $(use_enable samba vfs-smb)
+ $(use_enable sftp vfs-sftp)
+ $(use_enable spell aspell)
+ $(use_enable test tests)
+ $(use_with gpm gpm-mouse)
+ $(use_with X x)
+ $(use_with edit internal-edit)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # CK_FORK=no to avoid using fork() in check library
+ # as mc mocks fork() itself: bug #644462.
+ #
+ # VERBOSE=1 to make test failures contain detailed
+ # information.
+ CK_FORK=no emake check VERBOSE=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NEWS
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver
+ fperms g+s /usr/libexec/mc/cons.saver
+ fi
+
+ if ! use xdg ; then
+ sed 's@MC_XDG_OPEN="xdg-open"@MC_XDG_OPEN="/bin/false"@' \
+ -i "${ED%/}"/usr/libexec/mc/ext.d/*.sh || die
+ fi
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}