summaryrefslogtreecommitdiff
path: root/app-misc/khal/khal-0.9.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/khal/khal-0.9.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/khal/khal-0.9.7.ebuild')
-rw-r--r--app-misc/khal/khal-0.9.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.9.7.ebuild b/app-misc/khal/khal-0.9.7.ebuild
new file mode 100644
index 000000000000..794c616f1a86
--- /dev/null
+++ b/app-misc/khal/khal-0.9.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.1.3[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
+ dev-python/freezegun"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+ fi
+}