summaryrefslogtreecommitdiff
path: root/app-misc/khal/khal-0.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-05 22:12:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-05 22:12:15 +0100
commit0d3219165e816e09207a0e1b5b5c8ad764228615 (patch)
tree7efae0f8c1f3a14cf1039dc79a7841d094c1c4f2 /app-misc/khal/khal-0.11.2.ebuild
parent05a457a80598edba136fd3a23c4477ba2f80e77c (diff)
gentoo auto-resync : 05:07:2023 - 22:12:15
Diffstat (limited to 'app-misc/khal/khal-0.11.2.ebuild')
-rw-r--r--app-misc/khal/khal-0.11.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.11.2.ebuild b/app-misc/khal/khal-0.11.2.ebuild
new file mode 100644
index 000000000000..d7fb643f20fa
--- /dev/null
+++ b/app-misc/khal/khal-0.11.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="https://lostpackets.de/khal/ https://github.com/pimutils/khal"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-log[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
+
+distutils_enable_tests pytest