summaryrefslogtreecommitdiff
path: root/app-misc/khal/khal-0.10.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /app-misc/khal/khal-0.10.1-r3.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'app-misc/khal/khal-0.10.1-r3.ebuild')
-rw-r--r--app-misc/khal/khal-0.10.1-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.10.1-r3.ebuild b/app-misc/khal/khal-0.10.1-r3.ebuild
new file mode 100644
index 000000000000..008437f04e00
--- /dev/null
+++ b/app-misc/khal/khal-0.10.1-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_8 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-4.0.3[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
+ <dev-python/tzlocal-3[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]"
+BDEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+}