summaryrefslogtreecommitdiff
path: root/app-misc/jq/jq-1.6-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-misc/jq/jq-1.6-r3.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-misc/jq/jq-1.6-r3.ebuild')
-rw-r--r--app-misc/jq/jq-1.6-r3.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-misc/jq/jq-1.6-r3.ebuild b/app-misc/jq/jq-1.6-r3.ebuild
index 5517556e8d5d..f1172ab62ab9 100644
--- a/app-misc/jq/jq-1.6-r3.ebuild
+++ b/app-misc/jq/jq-1.6-r3.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
LICENSE="MIT CC-BY-3.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 x86 ~amd64-linux ~x64-macos"
IUSE="oniguruma static-libs"
ONIGURUMA_MINPV='>=dev-libs/oniguruma-6.1.3' # Keep this in sync with bundled modules/oniguruma/
@@ -60,6 +60,16 @@ src_configure() {
econf "${econfargs[@]}"
}
+src_test() {
+ if ! emake check; then
+ if [[ -r test-suite.log ]]; then
+ eerror "Tests failed, outputting testsuite log"
+ cat test-suite.log
+ fi
+ die "Tests failed"
+ fi
+}
+
src_install() {
local DOCS=( AUTHORS README.md )
default