summaryrefslogtreecommitdiff
path: root/app-misc/jpipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-misc/jpipe
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-misc/jpipe')
-rw-r--r--app-misc/jpipe/Manifest3
-rw-r--r--app-misc/jpipe/jpipe-0.1.3.1.ebuild42
-rw-r--r--app-misc/jpipe/metadata.xml19
3 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/jpipe/Manifest b/app-misc/jpipe/Manifest
new file mode 100644
index 000000000000..b132acfd3198
--- /dev/null
+++ b/app-misc/jpipe/Manifest
@@ -0,0 +1,3 @@
+DIST jpipe-0.1.3.1.tar.gz 5957 BLAKE2B ce7570006aa40ca61939c59a93608569898b0327d10a3ebce85e44ca33175a1fcf8412740008a648865ce5098594318154ad415505ed3167664c8726827402c7 SHA512 4dd90c4d59f1a3ca8a2417a20b95db9bb949c380104030a35053edb5e1c3a1bc73d28725cc18c0a3384181899198837f4d4abedaf9c7e374ec905e42ce1af4f6
+EBUILD jpipe-0.1.3.1.ebuild 969 BLAKE2B 4f5c6692c123df3a2fa818af24fdf03ef57a578ae6cee118feafdabda913ffee17431a465f3910082fea954242d50630a1393582b3a200631cf10fb1b4671caa SHA512 c926394af602e1745eee8a327c89b316539a195ddf83811494c8911820b6ceb0463239c603056504c0ad7c91abd96b1857cf730c4d9659f08781d419641de821
+MISC metadata.xml 540 BLAKE2B 48ce177f946eb9958b56d18688f8318f33ef14200c893f4645d2a26ac3d372b10b90775e1caa888c86051c3bc644c8f240581ab5ceed72c14cab6f9188f7a6a7 SHA512 8ba8fadf241f2ed2b25d5312293cf8c0d5410bc78e7f8cdca7607c9cef4a04297377ec13eea075deabaf2788cdd0b53a66488cb41887df6321e3fcf54ddf5265
diff --git a/app-misc/jpipe/jpipe-0.1.3.1.ebuild b/app-misc/jpipe/jpipe-0.1.3.1.ebuild
new file mode 100644
index 000000000000..a7ed62838505
--- /dev/null
+++ b/app-misc/jpipe/jpipe-0.1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python implementation of the jp CLI for JMESPath"
+HOMEPAGE="https://github.com/pipebus/jpipe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="jpp jp-symlink test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ jpp? ( !app-misc/jp[jpp] )
+ jp-symlink? ( !app-misc/jp[jp] )
+ dev-python/jmespath[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ if ! use jpp; then
+ sed -e '/jpp_main/d' -i setup.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test/test_jpipe.py || die "tests failed for ${EPYTHON}"
+ if use jpp; then
+ "${PYTHON}" test/test_jpp.py || die "jpp tests failed for ${EPYTHON}"
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ use jp-symlink && dosym jpipe /usr/bin/jp
+}
diff --git a/app-misc/jpipe/metadata.xml b/app-misc/jpipe/metadata.xml
new file mode 100644
index 000000000000..c1da5f3b0541
--- /dev/null
+++ b/app-misc/jpipe/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">pipebus/jpipe</remote-id>
+ <remote-id type="pypi">jpipe</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="jp-symlink">
+ Install a jp symlink that points to jpipe.
+ </flag>
+ <flag name="jpp">
+ Install jpp which is an extended superset of the jp CLI for JMESPath.
+ </flag>
+ </use>
+</pkgmetadata>