summaryrefslogtreecommitdiff
path: root/app-misc/ifp-line
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/ifp-line
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/ifp-line')
-rw-r--r--app-misc/ifp-line/Manifest4
-rw-r--r--app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch30
-rw-r--r--app-misc/ifp-line/ifp-line-0.3.ebuild39
-rw-r--r--app-misc/ifp-line/metadata.xml11
4 files changed, 84 insertions, 0 deletions
diff --git a/app-misc/ifp-line/Manifest b/app-misc/ifp-line/Manifest
new file mode 100644
index 000000000000..27009e440a7e
--- /dev/null
+++ b/app-misc/ifp-line/Manifest
@@ -0,0 +1,4 @@
+AUX ifp-line-0.3-fix-warnings.patch 1080 BLAKE2B 72e77b8d09dd077d399275ab5f46365be07278208281629416ccff43667c86d709b814c32163161c0e1e5bd4b5bf3dce76306b34a98e874ccb850065a3b83d3c SHA512 348fea237990df0531c32f688f888af2f247a318c711582d5a113531f1e28380c5b62d79947751c7f1180360459a883cd1e505f8e9ac04869fa68392d3a2b400
+DIST ifp-line-0.3.tar.gz 138272 BLAKE2B 249476938d111cc7609069f448b248921211cf298415951f4ea5043a8eff0eb80d11aeb1dab3d5d9db1aeed82b0de205d79945d4b0379762b62bc979485eb95e SHA512 516ad85fdaf69111581b013b2517c7083656436d429a86ec5ca4b7dcaf1c841538f98138cce8839d990a34550f11cc6bc9dedc701b0123b9cb73a91a7d78694d
+EBUILD ifp-line-0.3.ebuild 777 BLAKE2B dfec032550f13547f349b5c23fe570654e4fd04c7352c834eebe87324414dbafb8b1dd64d460cd24500ee329b708f6e65250120ca3b7556845b95cd575f14654 SHA512 f8359d1073a39edb527ded74cde0819675769c07d62a8da2505da31495cb338bb39bc15205d371d5cfec11787e7c1335cb8277ad6f40078409600e19a9080e0c
+MISC metadata.xml 333 BLAKE2B 87a4530824fff1355c5d2af1b6483b6fb1752c5a346b5848500b7962307a2e9956727f08e753b1548fbd941352a4563e9c14ae386bd46f238f8929cc2d46970b SHA512 d0cd8f6fc7bdc757d2a1ef5443f30410514ac335bcd2a84829995c527862b994fc75a8dfc5ceff2b8e2a3d7b0b081a57cbc50e4b825567b8a56d0f9eb00c13c7
diff --git a/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch b/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch
new file mode 100644
index 000000000000..a3bf5c24b95d
--- /dev/null
+++ b/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch
@@ -0,0 +1,30 @@
+--- a/unicodehack.c 2006-01-31 20:18:16.000000000 -0500
++++ b/unicodehack.c 2006-01-31 20:18:39.000000000 -0500
+@@ -26,7 +26,7 @@
+ return -1;
+ }
+
+- if ( (retval = iconv(cd, (const char **)&src, &srcln, &dst, &dstln)) == -1) {
++ if ( (retval = iconv(cd, (char **)&src, &srcln, &dst, &dstln)) == -1) {
+ // XXX ignore error message "iconv: Illiegal byte sequence"
+ // with GNU libiconv. No effect for output in now.
+ //perror("iconv");
+@@ -43,7 +43,7 @@
+ /**
+ * @return less then zero: error.
+ */
+-int unicode2locale(char *dst, size_t dstln, const char *src, size_t srcln) {
++int unicode2locale(char *dst, size_t dstln, char *src, size_t srcln) {
+ iconv_t cd;
+ int retval;
+
+--- a/unicodehack.h 2006-01-31 20:19:05.000000000 -0500
++++ b/unicodehack.h 2006-01-31 20:19:26.000000000 -0500
+@@ -4,6 +4,6 @@
+ #define IFPLINE_UNICODEHACK_H
+
+ extern int locale2unicode(char*, size_t, const char*, size_t);
+-extern int unicode2locale(char*, size_t, const char*, size_t);
++extern int unicode2locale(char*, size_t, char*, size_t);
+
+ #endif // IFPLINE_UNICODEHACK_H
diff --git a/app-misc/ifp-line/ifp-line-0.3.ebuild b/app-misc/ifp-line/ifp-line-0.3.ebuild
new file mode 100644
index 000000000000..ca5f7b8af6aa
--- /dev/null
+++ b/app-misc/ifp-line/ifp-line-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="iRiver iFP open-source driver"
+HOMEPAGE="http://ifp-driver.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ifp-driver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-warnings.patch" )
+
+src_install() {
+ dobin ifp || die
+ doman ifp.1
+
+ exeinto /usr/share/${PN}
+ doexe nonroot.sh || die
+ default
+}
+
+pkg_postinst() {
+ elog
+ elog "To enable non-root usage of ${PN}, you use any of the following"
+ elog "methods."
+ elog
+ elog " 1. Follow the TIPS file in"
+ elog " /usr/share/doc/${PF}"
+ elog
+ elog " 2. Run /usr/share/${PN}/nonroot.sh"
+ elog
+}
diff --git a/app-misc/ifp-line/metadata.xml b/app-misc/ifp-line/metadata.xml
new file mode 100644
index 000000000000..81812cad1e5b
--- /dev/null
+++ b/app-misc/ifp-line/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ifp-driver</remote-id>
+ </upstream>
+</pkgmetadata>