summaryrefslogtreecommitdiff
path: root/app-misc/hyfetch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-20 09:50:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-20 09:50:23 +0100
commit547caa904733bc2a3ac112415990a114ecbe8824 (patch)
treeb8976d40b28d2cb015e3c07254aee99fe0ad655a /app-misc/hyfetch
parent9346d46d1a9e0399ca3a4d3eb40689d0daa58ebc (diff)
gentoo auto-resync : 20:10:2023 - 09:50:23
Diffstat (limited to 'app-misc/hyfetch')
-rw-r--r--app-misc/hyfetch/Manifest5
-rw-r--r--app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch15
-rw-r--r--app-misc/hyfetch/hyfetch-1.4.10.ebuild40
-rw-r--r--app-misc/hyfetch/hyfetch-9999.ebuild36
-rw-r--r--app-misc/hyfetch/metadata.xml19
5 files changed, 115 insertions, 0 deletions
diff --git a/app-misc/hyfetch/Manifest b/app-misc/hyfetch/Manifest
new file mode 100644
index 000000000000..983adbef880c
--- /dev/null
+++ b/app-misc/hyfetch/Manifest
@@ -0,0 +1,5 @@
+AUX hyfetch-1.4.10-config_fix.patch 458 BLAKE2B af8e1dc998f2353a3883d7f6482e60cd7b5571cdaa1cd5022c1ea159b7b6e10a8fee8b98dbeebc83ccadf1c8ad1d4be6830dcc54609bbdfc9c813f0582b91b52 SHA512 76b6049795bf90c0e6a6d9e9b207d97abf994bcf8ed806dd10b56017bb0c396ff0055de47670b1b9580000f880bd0925e42e5cf5a00dc5dae030c17ea986cef6
+DIST hyfetch-1.4.10.tar.gz 266471 BLAKE2B 294002c2cd986055f6392aa61bb8de1d3d558712cd327243e7c2e756aa6e00ff23372fd0ffcc60db8f978110a3d8d1d78c6f683e304fc65b19d2f076e10347f2 SHA512 3f44bd9c0b030b435949db0c0cbd4913e7ec15e857df0dcf2fc3b7d10dca0a4c8ecb9862157f60eebd15b7a1c233c51a74f341b440892e0925871e42215c80e0
+EBUILD hyfetch-1.4.10.ebuild 1232 BLAKE2B c59a1b0fcc52ac57ed2ee8b071e2817a81101b39345468bb1b4349322a49aed9310de3a41d20dd5ec44afa59813be2ad005a151a8955abc4f4e6738e0d58c1e7 SHA512 7338f903d28ca10ca190d4a7e7211eb9d3f5c4de940d72bc16299d76cbaf1a7700d4884109015d802d2a5154bdbfe7c4b1a90840d1af28524b4b373195461b75
+EBUILD hyfetch-9999.ebuild 1175 BLAKE2B 1e1370acffe9c133310f82719f79f2d70067d48d4cda62b979393d8bc6337dbeab07a0149e31e06ee6b64a7e6318054f57797fa935c3a392eb698588d08188db SHA512 58845700bb290fae0558defdcadb5264a9e7a42a1c4a2ca94f04bc233722c23fed6123ea0bd2580c366fd12849d6f950ac4b2a6167b39d9d5cfdabcb0dc6b94a
+MISC metadata.xml 789 BLAKE2B ef77de73030b9f76fe7d11cf6aca05d795ae116881ee0d6d9ebc0cae7859e38736beca8e37067b32df0a3b063536dfe52d234e8af0005766cfa824d635cde771 SHA512 d40d3e0dc8be25f27b076b3b6a17a957a4307e9d585c1776717b1aceabaf83533bae0e2a4d7d8f8d904beadc4d4e634429bb87ce23445eae15ebe727d728cfa2
diff --git a/app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch b/app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch
new file mode 100644
index 000000000000..955eaf60ca30
--- /dev/null
+++ b/app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch
@@ -0,0 +1,15 @@
+check_config uses the global constant CONFIG_PATH instead
+of the path that gets passed to it.
+
+--- a/hyfetch/main.py
++++ b/hyfetch/main.py
+@@ -27,7 +27,7 @@ def check_config(path) -> Config:
+ """
+ if path.is_file():
+ try:
+- return Config.from_dict(json.loads(CONFIG_PATH.read_text('utf-8')))
++ return Config.from_dict(json.loads(path.read_text('utf-8')))
+ except KeyError:
+ return create_config()
+
+
diff --git a/app-misc/hyfetch/hyfetch-1.4.10.ebuild b/app-misc/hyfetch/hyfetch-1.4.10.ebuild
new file mode 100644
index 000000000000..8a6dd0d5a2f6
--- /dev/null
+++ b/app-misc/hyfetch/hyfetch-1.4.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit optfeature distutils-r1
+
+DESCRIPTION="Neofetch with LGBTQ+ pride flags!"
+HOMEPAGE="https://github.com/hykilpikonna/hyfetch"
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hykilpikonna/hyfetch.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hykilpikonna/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.10-config_fix.patch
+)
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+ elog "The standard neofetch is installed as 'neowofetch', to avoid name conflicts."
+ elog "So if you do not wish to use the pride flag functionality, you can call the"
+ elog "tool that way instead."
+}
diff --git a/app-misc/hyfetch/hyfetch-9999.ebuild b/app-misc/hyfetch/hyfetch-9999.ebuild
new file mode 100644
index 000000000000..448b872ef1ad
--- /dev/null
+++ b/app-misc/hyfetch/hyfetch-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit optfeature distutils-r1
+
+DESCRIPTION="Neofetch with LGBTQ+ pride flags!"
+HOMEPAGE="https://github.com/hykilpikonna/hyfetch"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hykilpikonna/hyfetch.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hykilpikonna/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+ elog "The standard neofetch is installed as 'neowofetch', to avoid name conflicts."
+ elog "So if you do not wish to use the pride flag functionality, you can call the"
+ elog "tool that way instead."
+}
diff --git a/app-misc/hyfetch/metadata.xml b/app-misc/hyfetch/metadata.xml
new file mode 100644
index 000000000000..3a8c9e49c124
--- /dev/null
+++ b/app-misc/hyfetch/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>baileykasin@gmail.com</email>
+ <name>Bailey Kasin</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en"> hyfetch builds upon neofetch to add pride flag coloration to the OS
+ logo, and also maintains the standard version of neofetch with bug fixes and new features,
+ as the original project is un-maintained. </longdescription>
+ <upstream>
+ <remote-id type="github">hykilpikonna/hyfetch</remote-id>
+ <bugs-to>https://github.com/hykilpikonna/hyfetch/issues</bugs-to>
+ </upstream>
+</pkgmetadata>