summaryrefslogtreecommitdiff
path: root/app-misc/hivex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/hivex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/Manifest3
-rw-r--r--app-misc/hivex/hivex-1.3.14.ebuild102
-rw-r--r--app-misc/hivex/metadata.xml8
3 files changed, 113 insertions, 0 deletions
diff --git a/app-misc/hivex/Manifest b/app-misc/hivex/Manifest
new file mode 100644
index 000000000000..dd72f18c5a65
--- /dev/null
+++ b/app-misc/hivex/Manifest
@@ -0,0 +1,3 @@
+DIST hivex-1.3.14.tar.gz 1332257 BLAKE2B fe7c19e05d29c7e98a334842cc1144aa76b148a3b7aae91449a4923a124eb54227a9a004346ef3558732c688c4f92cacd0c9328056930c33dba0404465634da0 SHA512 dd7dd52dceda580179a815fc48a2a2c7e8f7234614beceb937fba7e317df17984e65453338160c4c467b70d7d4f9bd61b48aad3ca51e19bd5e4cfbca8ee3adb6
+EBUILD hivex-1.3.14.ebuild 1847 BLAKE2B 2a60983c776c5fb1da55b47a1f4c8194cbda6513068320d03dc2f80dbb1eaa8f57f9f53cca9357b5c15eb594f532faf1452ef502cf0d6ace211fe1b3aa56058c SHA512 5c707cdd6fa4830bcdfabd020a4b09ac976ac8754fd75eb51cf4fef14eb128300f666fbac0bcd1df623dcc71e73eed681a1cfbe0e4ac5a4924b8c5c2974d82a4
+MISC metadata.xml 245 BLAKE2B 5599732e8923ea2b90a26adcb5708b6cf95cd3db28e810b9f881ac7d0e2c63745609f4c6e21708bdda7792f769df77bfa4b9d4d135eda71831efcaaab122c384 SHA512 1c6cdb75d4cbbd8d3a5f2cc24950924c030db330e135cf2cacecdaaa99ee65117efd7abd9f8652bf5dfa8169d427f51ff84123aab11fa8ef82498a6834b0805a
diff --git a/app-misc/hivex/hivex-1.3.14.ebuild b/app-misc/hivex/hivex-1.3.14.ebuild
new file mode 100644
index 000000000000..b3217d11ff1e
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.14.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+RUBY_OPTIONAL=yes
+
+PYTHON_COMPAT=(python2_7 python3_{4,5,6})
+
+inherit eutils perl-module ruby-ng python-single-r1
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ocaml readline +perl python test static-libs ruby"
+
+RDEPEND="
+ virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline:0 )
+ perl? ( dev-perl/IO-stringy )
+ ruby? ( $(ruby_implementations_depend) )
+ python? ( ${PYTHON_DEPS} )
+ "
+
+DEPEND="${RDEPEND}
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage )
+ )
+ "
+
+ruby_add_bdepend "ruby? ( dev-ruby/rake
+ virtual/rubygems
+ dev-ruby/rdoc )"
+ruby_add_rdepend "ruby? ( virtual/rubygems )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ ruby? ( || ( $(ruby_get_use_targets) ) )"
+
+DOCS=( README )
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+ cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all
+}
+
+src_configure() {
+ ruby-ng_src_configure
+
+ if use perl; then
+ pushd perl
+ perl-module_src_configure
+ popd
+ fi
+
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ --disable-ruby
+ $(use_enable python)
+ --disable-rpath
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ default
+ ruby-ng_src_compile
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake install DESTDIR="${ED}" "LINGUAS=""${LINGUAS}"""
+
+ ruby-ng_src_install
+
+ if use perl; then
+ perl_delete_localpod
+ fi
+}
diff --git a/app-misc/hivex/metadata.xml b/app-misc/hivex/metadata.xml
new file mode 100644
index 000000000000..c5adddd4b3e6
--- /dev/null
+++ b/app-misc/hivex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+</pkgmetadata>