summaryrefslogtreecommitdiff
path: root/app-misc/hivex/hivex-1.3.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-misc/hivex/hivex-1.3.18.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-misc/hivex/hivex-1.3.18.ebuild')
-rw-r--r--app-misc/hivex/hivex-1.3.18.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/app-misc/hivex/hivex-1.3.18.ebuild b/app-misc/hivex/hivex-1.3.18.ebuild
index f1c6db65034f..cace53ff05ef 100644
--- a/app-misc/hivex/hivex-1.3.18.ebuild
+++ b/app-misc/hivex/hivex-1.3.18.ebuild
@@ -8,7 +8,7 @@ RUBY_OPTIONAL=yes
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit eutils perl-module ruby-ng python-single-r1
+inherit l10n perl-module ruby-ng python-single-r1
DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
HOMEPAGE="https://libguestfs.org"
@@ -20,27 +20,28 @@ KEYWORDS="~amd64 ~x86"
IUSE="ocaml readline +perl python test ruby"
RDEPEND="
+ dev-libs/libxml2:2
virtual/libiconv
virtual/libintl
- dev-libs/libxml2:2
ocaml? ( dev-lang/ocaml[ocamlopt]
dev-ml/findlib[ocamlopt]
)
- readline? ( sys-libs/readline:0 )
perl? (
dev-lang/perl:=
dev-perl/IO-stringy
)
- ruby? ( $(ruby_implementations_depend) )
python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0 )
+ ruby? ( $(ruby_implementations_depend) )
"
DEPEND="${RDEPEND}
perl? (
- test? ( dev-perl/Pod-Coverage
- dev-perl/Test-Pod-Coverage )
- )
- "
+ test? (
+ dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage
+ )
+ )"
ruby_add_bdepend "ruby? ( dev-ruby/rake
virtual/rubygems
@@ -62,11 +63,11 @@ pkg_setup() {
src_unpack() {
default
- cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all
+ cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all || die
}
src_configure() {
- ruby-ng_src_configure
+ use ruby && ruby-ng_src_configure
if use perl; then
pushd perl
@@ -90,7 +91,8 @@ src_configure() {
src_compile() {
default
- ruby-ng_src_compile
+
+ use ruby && ruby-ng_src_compile
}
src_install() {
@@ -101,7 +103,7 @@ src_install() {
python_optimize
fi
- ruby-ng_src_install
+ use ruby && ruby-ng_src_install
if use perl; then
perl_delete_localpod