summaryrefslogtreecommitdiff
path: root/app-misc/hastyhex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
commitf932718a139f93e19a6883c061f81b365a408592 (patch)
tree216b44e4ea101b2d02ea32782355ed127f7b1df4 /app-misc/hastyhex
parentf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (diff)
gentoo auto-resync : 04:11:2022 - 21:16:37
Diffstat (limited to 'app-misc/hastyhex')
-rw-r--r--app-misc/hastyhex/Manifest3
-rw-r--r--app-misc/hastyhex/hastyhex-1.0.0.ebuild23
-rw-r--r--app-misc/hastyhex/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/hastyhex/Manifest b/app-misc/hastyhex/Manifest
new file mode 100644
index 000000000000..7860bb4a2b17
--- /dev/null
+++ b/app-misc/hastyhex/Manifest
@@ -0,0 +1,3 @@
+DIST hastyhex-1.0.0.tar.xz 4924 BLAKE2B 68b3819f8877a12eb86344b30db6aa970e36d82285e6784ccc1399e8385c1afc7b605b0ad7cac3864b473afb8bb3eb04ab56d29b90ef8604862d26c7c79b615f SHA512 e72dc7b233e37f01e553de6538506c5691f6307556fa49c67a257ec360cdf96c5a0db3802513d66fc6eedd944525cc055af72e29f2998551144577703972a71d
+EBUILD hastyhex-1.0.0.ebuild 482 BLAKE2B f658b133da04772b565db88157f4a8bf9f518cac6e340b4b88708cdd518a23c20a5d1cb70276da69443722f856d71c24f242c8e7e6f462e410960e795e93c149 SHA512 0293a3ebcaf2813e87e9bd30027197be513dc7cad8fc070eb9ad4359cae1e6736619873b1fb84f965d0076de883b67e8bdfcb28543645028b4eb921f69abefa6
+MISC metadata.xml 328 BLAKE2B d05343450ec7dca3fd1ff87a2d1da794a626cb9e88e8c0612ccaee5992e60201cc3f0948bfbbdbaf1843095fa720d3b3d45301cdf437db5d87f5987977ad4b61 SHA512 6645f81323db41e63b57f8d875f1bc0974975dfeb0abba4b4362dd7d81f638ce54daa7d52d0b88bafc1685282c54a3c7b5c1d4693468a11538995c70f2d5d43b
diff --git a/app-misc/hastyhex/hastyhex-1.0.0.ebuild b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
new file mode 100644
index 000000000000..87471bff2613
--- /dev/null
+++ b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A blazing fast hex dumper"
+HOMEPAGE="https://github.com/skeeto/hastyhex"
+SRC_URI="https://github.com/skeeto/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}
diff --git a/app-misc/hastyhex/metadata.xml b/app-misc/hastyhex/metadata.xml
new file mode 100644
index 000000000000..0e6b145389f8
--- /dev/null
+++ b/app-misc/hastyhex/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matthew@gentoo.org</email>
+ <name>Matthew Smith</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">skeeto/hastyhex</remote-id>
+ </upstream>
+</pkgmetadata>