summaryrefslogtreecommitdiff
path: root/app-misc/gtk-sunlight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
commitc9c609463fab9bcfb35694627bca1429a21fdbb2 (patch)
tree024860c3c54aa33cdb6972acd3e2e0b8484f3aa7 /app-misc/gtk-sunlight
parent6dd9db91dd6ce9bbe3197aa82642866e637ba68d (diff)
gentoo auto-resync : 31:10:2022 - 21:05:59
Diffstat (limited to 'app-misc/gtk-sunlight')
-rw-r--r--app-misc/gtk-sunlight/Manifest3
-rw-r--r--app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch32
-rw-r--r--app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r2.ebuild (renamed from app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r1.ebuild)8
3 files changed, 40 insertions, 3 deletions
diff --git a/app-misc/gtk-sunlight/Manifest b/app-misc/gtk-sunlight/Manifest
index 12f6ad417bae..a163a582b5e8 100644
--- a/app-misc/gtk-sunlight/Manifest
+++ b/app-misc/gtk-sunlight/Manifest
@@ -1,3 +1,4 @@
+AUX gtk-sunlight-0.4.2-fix-function-declarations.patch 1045 BLAKE2B 10c35708625d996230e025dd33f53677e89de610b18dc38474dae78d6cc2212eaa95ec47bf0db13c50dc79c87744ad4720bad5f9555193cc2b16114223411f08 SHA512 271afc0266106ccfd1b5b689004e6cd84c261eebb4d3a8f1141e31070fc47f07b4d1946784564cfa620e387112ec4cf015431c8b4c26e077604161bea06955eb
DIST gtk-sunlight_0.4.2.orig.tar.gz 562581 BLAKE2B 6fd80fd0324de2e7fbe5cf72eddecee128abe4d4d4cb13c30c224241f1fb99a8683bce43f2b60dc309ac9479f424bd31db5a5c2c659a36da0266b3fc58cd687c SHA512 6490172beeb4c3566a42de858e321cdf83be6852d5c290f75f41d22855d002e8609948164cb757e787a1123a4fe47b69272996ffc821c057b7c6ce8b0b180083
-EBUILD gtk-sunlight-0.4.2-r1.ebuild 566 BLAKE2B fab12ed2954eda60aaa1b3064683dc88b566c4d7ca96da0678ee718a36603af02e9892b67cf987be049adb54a70bae8b99dba406bd3d79a21adc4935244dbd31 SHA512 a99f5b575e19b0f6398abfc42274b86c30f74790048997873d0d57ab585911fbfcdf4032fb168de1992d782bc65459a0176fae2c229417f96a0cf66fb76d48bf
+EBUILD gtk-sunlight-0.4.2-r2.ebuild 631 BLAKE2B 15923bed64814e553eb32c2846b7fc164a8cb43832bbc8ccb8f66ca7bdfff0d950c90d89822a12bda8650ed5996d7466340866df1c60c9bc1fd1aec362a3a2ae SHA512 84ffcb7085f6357b6a34459436d318bf031e2b572e12baa6a74443b02f807bd6f6799af99a0d8271198cbe9164c6791d2b8f219ad25c21c881d28cc5fbb75515
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch b/app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch
new file mode 100644
index 000000000000..bdf4e616d486
--- /dev/null
+++ b/app-misc/gtk-sunlight/files/gtk-sunlight-0.4.2-fix-function-declarations.patch
@@ -0,0 +1,32 @@
+Fix implicit function declarations as they are not supported by clang16 with standard settings.
+
+Bug: https://bugs.gentoo.org/874717
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+
+--- a/callbacks.c
++++ b/callbacks.c
+@@ -33,6 +33,12 @@ gpointer create_progressbar_window (ChData *data);
+ gboolean update_progress(gpointer data);
+ gpointer async_lengthy_func(gpointer data);
+
++extern void scale_box_sensitive (ChData *data, gboolean sensitive);
++extern gshort move_earth_true (ChData *data);
++extern void get_and_set_options (ChData *data);
++extern gshort get_map_position (ChData *data);
++extern gboolean is_peters (ChData *data);
++extern void button_sensitive (ChData *data, gboolean sensitive);
+ /***************************************
+ Window Callbacks
+ ***************************************/
+--- a/sunlight.c
++++ b/sunlight.c
+@@ -19,6 +19,8 @@
+
+ #include "support.h"
+
++extern void change_wallpaper (ChData *data);
++
+ void initialize_variables (ChData *data){
+ data->var.gi_rd1 = 1;
+ data->var.gi_rd2 = 1;
diff --git a/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r1.ebuild b/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r2.ebuild
index e98885b1e722..223a18a74a99 100644
--- a/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r1.ebuild
+++ b/app-misc/gtk-sunlight/gtk-sunlight-0.4.2-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs xdg
@@ -20,6 +20,10 @@ RDEPEND="
x11-libs/gtk+:3"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-function-declarations.patch
+)
+
src_compile() {
tc-export CC
default