summaryrefslogtreecommitdiff
path: root/app-misc/gramps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 04:28:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 04:28:45 +0100
commit7e110ec617b903791c3d309845e11a8b27f441cc (patch)
treed9e8b4826e21ef9fa1fc2255d459f563d5581283 /app-misc/gramps
parentf2a91413828611d85d0496e98e1656e9b0e4528b (diff)
gentoo auto-resync : 11:07:2023 - 04:28:45
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/Manifest2
-rw-r--r--app-misc/gramps/gramps-5.1.6-r1.ebuild (renamed from app-misc/gramps/gramps-5.1.6.ebuild)49
2 files changed, 17 insertions, 34 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index a6806ce866a6..c300700f4b08 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -2,5 +2,5 @@ AUX gramps-5.1.3-test_locale.patch 1195 BLAKE2B 1b1aeb08b90bff9db9d028499428efa6
DIST gramps-5.1.5.tar.gz 17425167 BLAKE2B f07fcb84c28f1def84c5568da6ac38a78def8657a0ee010163cb7e0899dd94ebb1c851e2c9d207fd9725754363ac7243a66f0de6e0d9708270d2d43c90485212 SHA512 8e36e8da7cfb41cc0c77881993cfc212a15bf9775dad3c8be131889b70360117e023b6837b91dad28fc03198080290a08c8089856c753246ff14c7fc3bca38be
DIST gramps-5.1.6.tar.gz 17429153 BLAKE2B fe94d80ff209e1f27ec1cfa533e916514336c1d367435e0a9da4b8309efbc9c047302a67ec24e28237eaead67ff63e76bd1384ac1e3df10e08ae98aca126566b SHA512 419bbfa54ca3bf33e71fd579c84a56eebe4afc78ccd50c23b2d62869684709ccbf373e8da0e65835d9fc21a29d2d144597d6cf8c425e14c91574535d4b1ab64d
EBUILD gramps-5.1.5.ebuild 2910 BLAKE2B 23b626f1dbcb0b4076162b855a3adbb43ebd0d2124173be5df10fc0f79baec1d41dc4f954ca05b68d265010726fa6e308d8c45f859dd086c50709c00920ec836 SHA512 a4dba3514bf4cd44a3472de3741ea9ea97bd240a706aa9049152946485c61f1e737a1c4fcee083189a1ae0eaff298ebf704b812c10f6e40f1552c59c167f30ad
-EBUILD gramps-5.1.6.ebuild 2795 BLAKE2B e7575bfda3e64bb818eb7535ea1ca6cbb2cae9e146b23c8916d3e475257fa00324b36147ea0f949b1a20883d4d87485c0002e5b949ba9761f9c5d34f8e8a39c0 SHA512 dbb0d03df6123d80f4fb367c5d9025982e914d1d366655be22830c5f58c0165e198aec33add06e5e35efa9c92981102c1cede62b8183470c88363da5ba67cd0b
+EBUILD gramps-5.1.6-r1.ebuild 2156 BLAKE2B 13b504c32e687156be9da756b20063cc0a449f68ffcf08846cdac421ec268599a418c35e33b718d07671e081b9bfea3e0d0944141184c367bccc29795ef03b01 SHA512 48e4ea73dcdc1c099d9f029d8eb887409729a25568c70a7de5730de4e0580fd2ad2d9c7b3d65f9a6fbdc3871a28977e9e15e332918a830460c7b4de198062aca
MISC metadata.xml 5703 BLAKE2B 1c4879fcccfb62b99140eff6e5059129bc75b0a6f5f6d55167981b0ca3476e286a786caec2452c5aa9690e287c7142e3e443edc7ef8ad1d6ea4002d37f624647 SHA512 c3c926d1da8d57f5dc3b9f0691299552aceeef437e01f9385a6555c5fcf1ffea82fd1f9e87f20e23bc54d7578e0819786f1d1bc59d633cc30bbd9e79f236f3b5
diff --git a/app-misc/gramps/gramps-5.1.6.ebuild b/app-misc/gramps/gramps-5.1.6-r1.ebuild
index 35795730b469..01e06e6e7b85 100644
--- a/app-misc/gramps/gramps-5.1.6.ebuild
+++ b/app-misc/gramps/gramps-5.1.6-r1.ebuild
@@ -3,13 +3,10 @@
EAPI=8
-DISTUTILS_SINGLE_IMPL=1
-# Sadly, PEP-517 mode breaks both the test suite and the installation of some of the data files
-DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="sqlite"
-inherit distutils-r1 xdg-utils
+inherit python-single-r1 xdg-utils
DESCRIPTION="Community genealogy program aiming to be both intuitive and feature-complete"
HOMEPAGE="https://gramps-project.org/"
@@ -21,10 +18,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="exif geo postscript +rcs +reports spell test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
# Some of the tests fail unless the deprecated BerkeleyDB back-end is enabled.
RESTRICT="test"
-RDEPEND="
+RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pycairo[${PYTHON_USEDEP}]
>=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
@@ -41,6 +40,7 @@ RDEPEND="
reports? ( media-gfx/graphviz[postscript?] )
"
BDEPEND="test? (
+ ${RDEPEND}
$(python_gen_cond_dep '
dev-python/jsonschema[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
@@ -51,44 +51,27 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.1.3-test_locale.patch
)
-distutils_enable_tests setup.py
-
-python_prepare_all() {
+src_prepare() {
# Install documentation to the proper location. This can't be done
# easily with a patch because we substitute in the ${PF} variable,
# and that changes with every revision.
sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
- distutils-r1_python_prepare_all
-}
-python_configure_all() {
- DISTUTILS_ARGS=(
- --resourcepath=/usr/share
- --no-compress-manpages
- )
+ default
}
-python_test() {
- # Gramps builds just fine out of tree but it confuses its test suite.
- # The following at least lets the tests run properly in legacy mode.
- rm -rf "${S}/build" && ln -s "${BUILD_DIR}" "${S}"/build || \
- die "Failed to symlink build directory to source directory"
-
- # Set a sane default locale for the tests which do not explicitly set one.
- local -x LC_ALL=C.UTF-8
+src_compile() {
+ ${PYTHON} setup.py --verbose build || die
+}
- esetup.py test || die
+src_test() {
+ LC_ALL=C.UTF-8 ${PYTHON} setup.py --verbose test || die
}
-# Ugly hack to work around Bug #717922
-python_install() {
- local DISTUTILS_ARGS=(
- --resourcepath=/usr/share
- --no-compress-manpages
- build
- )
- distutils-r1_python_install
- echo -n "${EPREFIX}/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
+src_install() {
+ ${PYTHON} setup.py --verbose install --root="${ED}" --resourcepath=/usr/share --no-compress-manpages || die
+ einstalldocs
+ python_optimize
}
pkg_postinst() {