summaryrefslogtreecommitdiff
path: root/app-misc/gramps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-misc/gramps
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/Manifest2
-rw-r--r--app-misc/gramps/gramps-5.1.5.ebuild114
2 files changed, 116 insertions, 0 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index 08fe582dccc2..d66775ea97fe 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1,4 +1,6 @@
AUX gramps-5.1.3-test_locale.patch 1195 BLAKE2B 1b1aeb08b90bff9db9d028499428efa60a16b48597bcf466c07a77e3f658c8550eca84b899047d1bc6e20eb26e8dfab9637ae7aced1b99167466ea6c51707132 SHA512 70daee9afdce0f939ad3cec094fb4004f5c162e6b49849f83486db5baec074a8673d7a6096a367279019712a11f0b40e827f6cb3019e7dc3cc6bad327fee35ec
DIST gramps-5.1.4.tar.gz 17425713 BLAKE2B 9b3761906b70ed6b85112e502290013cf421669418355ed0dc54d00adbcc2af4cd74c596bacaad50cdac6457e7a3b7675d4afb7b471fd471af8b7a6adae3ad82 SHA512 f43fc250142968331db1875260577e022898cff2d1453ee6b74be760d798b75cfdf93492d8d823dbb094da2ddd96a4f249e813c603e7cd9d0585641424284734
+DIST gramps-5.1.5.tar.gz 17425167 BLAKE2B f07fcb84c28f1def84c5568da6ac38a78def8657a0ee010163cb7e0899dd94ebb1c851e2c9d207fd9725754363ac7243a66f0de6e0d9708270d2d43c90485212 SHA512 8e36e8da7cfb41cc0c77881993cfc212a15bf9775dad3c8be131889b70360117e023b6837b91dad28fc03198080290a08c8089856c753246ff14c7fc3bca38be
EBUILD gramps-5.1.4.ebuild 3485 BLAKE2B 7efd6512d7e337a516056ef5f2bc06f9a7725e094e91395914ca582ab41428675607dd6b4532e13d85e54c8f6a8d45dae515dad87719a6db2c854cc034ec20ab SHA512 b9ad8d41bb15d171b8ccd5ae4d28c8c1241657cb1fa782531135d54a35470998a8a2203b134b40814161d38e3fd13f3c67099599cb3bcbf17f9d987bd00b08f7
+EBUILD gramps-5.1.5.ebuild 3378 BLAKE2B 8d846a8b062ea2d6650d1e0462e830656b3b8f2e7a9ee68a50ecee18fdf30cb2213c24d33be0f0c6b37fa159d02bf5223b9c74a061c9cb46c75801d22b9142d2 SHA512 284ea360d2e195295565aaeefff4f243fd8886726efc107670efd12203a2f380738852cfaafa01a905ae9fd4e8b5d43f0c09227984bff414c1e077c7ef6d0fa0
MISC metadata.xml 5703 BLAKE2B 1c4879fcccfb62b99140eff6e5059129bc75b0a6f5f6d55167981b0ca3476e286a786caec2452c5aa9690e287c7142e3e443edc7ef8ad1d6ea4002d37f624647 SHA512 c3c926d1da8d57f5dc3b9f0691299552aceeef437e01f9385a6555c5fcf1ffea82fd1f9e87f20e23bc54d7578e0819786f1d1bc59d633cc30bbd9e79f236f3b5
diff --git a/app-misc/gramps/gramps-5.1.5.ebuild b/app-misc/gramps/gramps-5.1.5.ebuild
new file mode 100644
index 000000000000..8261bdb45c89
--- /dev/null
+++ b/app-misc/gramps/gramps-5.1.5.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: py3.10 support (currently blocked by media-libs/gexiv2)
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Community genealogy program aiming to be both intuitive and feature-complete"
+HOMEPAGE="https://gramps-project.org/"
+SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb exif geo postscript +rcs +reports spell test"
+
+RESTRICT="!test? ( test )
+ !berkdb? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyicu[${PYTHON_USEDEP}]
+ exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+ ')
+ gnome-base/librsvg:2
+ >x11-libs/gtk+-3.14.8:3[introspection]
+ x11-libs/pango[introspection]
+ x11-misc/xdg-utils
+ berkdb? ( $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ ' python3_{8,9}) )
+ geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ spell? ( app-text/gtkspell:3[introspection] )
+ rcs? ( dev-vcs/rcs )
+ reports? ( media-gfx/graphviz[postscript?] )
+"
+BDEPEND="test? ( ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.1.3-test_locale.patch
+)
+
+python_prepare_all() {
+ # Install documentation to the proper location. This can't be done
+ # easily with a patch because we substitute in the ${PF} variable,
+ # and that changes with every revision.
+ sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ )
+}
+
+python_test() {
+ # Gramps builds just fine out of tree but it confuses its test suite.
+ # The following might be an ugly hack but at least it lets the tests
+ # run properly until either I or upstream have come up with something
+ # better. FIXME: test this when a new release comes out.
+ rm -rf "${S}/build" && ln -s "${BUILD_DIR}" "${S}"/build || \
+ die "Failed to symlink build directory to source directory"
+
+ # Set a sane default locale for the tests which do not explicitly set one.
+ local -x LC_ALL=C.UTF-8
+
+ esetup.py test || die
+}
+
+# Ugly hack to work around Bug #717922
+python_install() {
+ local DISTUTILS_ARGS=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ build
+ )
+ distutils-r1_python_install
+ echo -n "${EPREFIX}/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+
+ if use berkdb; then
+ ewarn "The BSDDB back-end in ${PN} has got known stability and data-corruption issues. It has been deprecated since version 5.1.0 and might be removed in 5.2.0."
+ ewarn "If you have any family trees in this format you are highly advised to convert them to SQLite, as described here:"
+ ewarn
+ ewarn "https://gramps-project.org/wiki/index.php/Gramps_5.1_Wiki_Manual_-_Manage_Family_Trees#Converting_a_BSDDB_Family_Tree_to_SQLite"
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}