summaryrefslogtreecommitdiff
path: root/app-misc/gramps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
commit49307b439ea0ae14beb0772de83e70297ae8356c (patch)
tree02f22afc29810c4558bf87d13c56f288d43fecc3 /app-misc/gramps
parent99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (diff)
gentoo auto-resync : 09:07:2023 - 04:23:59
Diffstat (limited to 'app-misc/gramps')
-rw-r--r--app-misc/gramps/Manifest2
-rw-r--r--app-misc/gramps/gramps-5.1.6.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index 601fa0d0be03..a6806ce866a6 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1,4 +1,6 @@
AUX gramps-5.1.3-test_locale.patch 1195 BLAKE2B 1b1aeb08b90bff9db9d028499428efa60a16b48597bcf466c07a77e3f658c8550eca84b899047d1bc6e20eb26e8dfab9637ae7aced1b99167466ea6c51707132 SHA512 70daee9afdce0f939ad3cec094fb4004f5c162e6b49849f83486db5baec074a8673d7a6096a367279019712a11f0b40e827f6cb3019e7dc3cc6bad327fee35ec
DIST gramps-5.1.5.tar.gz 17425167 BLAKE2B f07fcb84c28f1def84c5568da6ac38a78def8657a0ee010163cb7e0899dd94ebb1c851e2c9d207fd9725754363ac7243a66f0de6e0d9708270d2d43c90485212 SHA512 8e36e8da7cfb41cc0c77881993cfc212a15bf9775dad3c8be131889b70360117e023b6837b91dad28fc03198080290a08c8089856c753246ff14c7fc3bca38be
+DIST gramps-5.1.6.tar.gz 17429153 BLAKE2B fe94d80ff209e1f27ec1cfa533e916514336c1d367435e0a9da4b8309efbc9c047302a67ec24e28237eaead67ff63e76bd1384ac1e3df10e08ae98aca126566b SHA512 419bbfa54ca3bf33e71fd579c84a56eebe4afc78ccd50c23b2d62869684709ccbf373e8da0e65835d9fc21a29d2d144597d6cf8c425e14c91574535d4b1ab64d
EBUILD gramps-5.1.5.ebuild 2910 BLAKE2B 23b626f1dbcb0b4076162b855a3adbb43ebd0d2124173be5df10fc0f79baec1d41dc4f954ca05b68d265010726fa6e308d8c45f859dd086c50709c00920ec836 SHA512 a4dba3514bf4cd44a3472de3741ea9ea97bd240a706aa9049152946485c61f1e737a1c4fcee083189a1ae0eaff298ebf704b812c10f6e40f1552c59c167f30ad
+EBUILD gramps-5.1.6.ebuild 2795 BLAKE2B e7575bfda3e64bb818eb7535ea1ca6cbb2cae9e146b23c8916d3e475257fa00324b36147ea0f949b1a20883d4d87485c0002e5b949ba9761f9c5d34f8e8a39c0 SHA512 dbb0d03df6123d80f4fb367c5d9025982e914d1d366655be22830c5f58c0165e198aec33add06e5e35efa9c92981102c1cede62b8183470c88363da5ba67cd0b
MISC metadata.xml 5703 BLAKE2B 1c4879fcccfb62b99140eff6e5059129bc75b0a6f5f6d55167981b0ca3476e286a786caec2452c5aa9690e287c7142e3e443edc7ef8ad1d6ea4002d37f624647 SHA512 c3c926d1da8d57f5dc3b9f0691299552aceeef437e01f9385a6555c5fcf1ffea82fd1f9e87f20e23bc54d7578e0819786f1d1bc59d633cc30bbd9e79f236f3b5
diff --git a/app-misc/gramps/gramps-5.1.6.ebuild b/app-misc/gramps/gramps-5.1.6.ebuild
new file mode 100644
index 000000000000..35795730b469
--- /dev/null
+++ b/app-misc/gramps/gramps-5.1.6.ebuild
@@ -0,0 +1,104 @@
+# Copyright 2001-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+# Sadly, PEP-517 mode breaks both the test suite and the installation of some of the data files
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Community genealogy program aiming to be both intuitive and feature-complete"
+HOMEPAGE="https://gramps-project.org/"
+SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif geo postscript +rcs +reports spell test"
+
+# Some of the tests fail unless the deprecated BerkeleyDB back-end is enabled.
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyicu[${PYTHON_USEDEP}]
+ exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+ ')
+ gnome-base/librsvg:2
+ >x11-libs/gtk+-3.14.8:3[introspection]
+ x11-libs/pango[introspection]
+ x11-misc/xdg-utils
+ geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ spell? ( app-text/gtkspell:3[introspection] )
+ rcs? ( dev-vcs/rcs )
+ reports? ( media-gfx/graphviz[postscript?] )
+"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.1.3-test_locale.patch
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # Install documentation to the proper location. This can't be done
+ # easily with a patch because we substitute in the ${PF} variable,
+ # and that changes with every revision.
+ sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ )
+}
+
+python_test() {
+ # Gramps builds just fine out of tree but it confuses its test suite.
+ # The following at least lets the tests run properly in legacy mode.
+ rm -rf "${S}/build" && ln -s "${BUILD_DIR}" "${S}"/build || \
+ die "Failed to symlink build directory to source directory"
+
+ # Set a sane default locale for the tests which do not explicitly set one.
+ local -x LC_ALL=C.UTF-8
+
+ esetup.py test || die
+}
+
+# Ugly hack to work around Bug #717922
+python_install() {
+ local DISTUTILS_ARGS=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ build
+ )
+ distutils-r1_python_install
+ echo -n "${EPREFIX}/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}