summaryrefslogtreecommitdiff
path: root/app-misc/grabcartoons/grabcartoons-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/grabcartoons/grabcartoons-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/grabcartoons/grabcartoons-9999.ebuild')
-rw-r--r--app-misc/grabcartoons/grabcartoons-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/grabcartoons/grabcartoons-9999.ebuild b/app-misc/grabcartoons/grabcartoons-9999.ebuild
new file mode 100644
index 000000000000..77fbcd8f86b9
--- /dev/null
+++ b/app-misc/grabcartoons/grabcartoons-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/zzamboni/grabcartoons/archive/cb230f01fb288a0b9f0fc437545b97d06c846bd3.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Comic-summarizing utility"
+HOMEPAGE="http://zzamboni.org/grabcartoons"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+# Opens a web page, which is unacceptable during an emerge.
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+PATCHES=( "${FILESDIR}"/2.8.4-fix-install-paths.patch )
+
+src_install() {
+ emake PREFIX="${ED%/}"/usr install
+ einstalldocs
+}