summaryrefslogtreecommitdiff
path: root/app-misc/golly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /app-misc/golly
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'app-misc/golly')
-rw-r--r--app-misc/golly/Manifest3
-rw-r--r--app-misc/golly/golly-3.3-r1.ebuild51
-rw-r--r--app-misc/golly/golly-3.3.ebuild12
3 files changed, 57 insertions, 9 deletions
diff --git a/app-misc/golly/Manifest b/app-misc/golly/Manifest
index 456930b66afe..a9d2c0be9027 100644
--- a/app-misc/golly/Manifest
+++ b/app-misc/golly/Manifest
@@ -3,5 +3,6 @@ AUX golly-3.2-mouse-2.patch 1553 BLAKE2B 34e8a85532ca7176fa4f587438662b760a72d97
DIST golly-3.2-src.tar.gz 5261483 BLAKE2B c9a1c09c71bafcb624eab91c7b86d671bd0cec23041d5ada91972c363242a4bc0c55d699f45e9b732dd00d4f030818a51f9c1e4ccafed298e230d912d4d22235 SHA512 bff5bbe75c0914bfcd416101894f8be1fd644c147fb90e0ad2cf87b4472c132c5d50be1829345fae59038e3d2e106ac417c5bc3cbc5c7d3a32a03c241b7a8eca
DIST golly-3.3-src.tar.gz 5465595 BLAKE2B e74da3799d1086a46fba523e6b087e6bc50c908098b27a80573936629fd5ad6195968df46b2933a9984cff85068222a80040761254298c5f648b040d5532a7ba SHA512 2aa9c2e7b2ebe3fe85bcb6177e58ee83bd08475e0a37a04cdb7e649b9faf5c2f936c534af62c8cf2322baade65c6e5197768901dfb464c17b20b941e1fa77265
EBUILD golly-3.2.ebuild 1148 BLAKE2B a753b5b303d6d59ea2cb9f596367c473896328947b64214cecb53d59082292c9f38e553127142b25ca6e0f52ab379f25a52ccd95d54c258ccdbe6a831877f4ac SHA512 5192b0c80ea964422fb49e607af8e0ac68a8dced02182a38cea1c0fea5583a07784ff8ffc6f47f56c5b9f41d217717e9dab776920c1872b0b137f8c3fb07bc43
-EBUILD golly-3.3.ebuild 1070 BLAKE2B f1d227c74b7a0b2974643d6ac296dcd7a435072aa4f0d2b632f4caa3143a0bb889dc4a1c94461536e7f518de6246a513f27ccb1db79405bbfbb2a5ae1bcb4ec2 SHA512 32dc8bc6e44b73198fc92110610438d4e4988bf11567e5d5396fa8126111746d9ca7e08a7c58ff54916b83b1592cd451644fae4c8f9bfb100c89908373ddc16a
+EBUILD golly-3.3-r1.ebuild 1026 BLAKE2B 8cde2168e0b3ee5608ad790dc1d6197f715d012260bdecdc572e5a5c4ebe2887ef612b17b4064b8b1f2fc6a127ac067f678c79afad774a7bd053c95010860d5c SHA512 e14e63e356a06d1e78c0837636c3d34cca9ead96c5e10ded6f119c0df00f6a7cc968108e4a9017389973fe26441f4e56cd71618263bad4780fc0265e8fa82018
+EBUILD golly-3.3.ebuild 1028 BLAKE2B 28d361d337836b78321ee373eb8b6b08b6bfa387c1af6cf5cabddce7fee0f82960a013bf38d8d98c3c7e0c20ca98a1287024ed71357f44d3d0e7becc45420366 SHA512 7106647455ff3b6a2754ddda2c07aee65a129d7021a4e22f9c9561ca10301836967e3840b9181ddeb2bdeeaf4cb910e4ba9c2181e5f1b75bda216a60fa5398df
MISC metadata.xml 326 BLAKE2B 6064832ecd0867971a46cd3c998419df96a09aea31c361b98cc81212e1a84bb99053f14a86321b194196df7e74d1859d7c82c2f55adcf0dd887224754aed381e SHA512 be4d2ed3256cbb48987657dc4a6569c4fa415a495488f17bffe0954bd54127bfc4f6652912b18666a02887bfe31769d1b0c1a67c311e286abca347a9b756301f
diff --git a/app-misc/golly/golly-3.3-r1.ebuild b/app-misc/golly/golly-3.3-r1.ebuild
new file mode 100644
index 000000000000..26742c324c99
--- /dev/null
+++ b/app-misc/golly/golly-3.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER=3.0
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop eutils flag-o-matic python-single-r1 wxwidgets xdg-utils
+
+DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="tiff"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="virtual/opengl
+ sys-libs/zlib
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,tiff?]"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${P}-src
+
+pkg_setup() {
+ setup-wxwidgets
+}
+
+src_configure() {
+ ECONF_SOURCE=gui-wx/configure econf \
+ --with-wxshared
+}
+
+src_install() {
+ emake docdir= DESTDIR="${D}" install
+ dodoc docs/ReadMe.html
+ newicon --size 32 gui-wx/icons/appicon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Golly" ${PN} "Science"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/app-misc/golly/golly-3.3.ebuild b/app-misc/golly/golly-3.3.ebuild
index f3319b32e24b..dffedc97b55a 100644
--- a/app-misc/golly/golly-3.3.ebuild
+++ b/app-misc/golly/golly-3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
WX_GTK_VER=3.0
PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic python-single-r1 gnome2-utils wxwidgets
+inherit desktop eutils flag-o-matic python-single-r1 wxwidgets xdg-utils
DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
HOMEPAGE="http://golly.sourceforge.net/"
@@ -42,14 +42,10 @@ src_install() {
make_desktop_entry ${PN} "Golly" ${PN} "Science"
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}