summaryrefslogtreecommitdiff
path: root/app-misc/golly/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /app-misc/golly/files
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'app-misc/golly/files')
-rw-r--r--app-misc/golly/files/golly-3.3-allow-py23-exec.patch12
-rw-r--r--app-misc/golly/files/golly-3.3-allow-py3.patch90
-rw-r--r--app-misc/golly/files/golly-3.3-glife-py23.patch32
-rw-r--r--app-misc/golly/files/golly-3.3-nondynamic-python.patch51
4 files changed, 0 insertions, 185 deletions
diff --git a/app-misc/golly/files/golly-3.3-allow-py23-exec.patch b/app-misc/golly/files/golly-3.3-allow-py23-exec.patch
deleted file mode 100644
index e46b608ed6c5..000000000000
--- a/app-misc/golly/files/golly-3.3-allow-py23-exec.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-'execfile' is python-2-only. 'exec/open' works for both python2 and python3.
---- a/gui-wx/wxpython.cpp
-+++ b/gui-wx/wxpython.cpp
-@@ -3356,7 +3388,7 @@ void RunPythonScript(const wxString& filepath)
- // for the global namespace so that this script cannot change the
- // globals of a caller script (which is possible now that RunScript
- // is re-entrant)
-- wxString command = wxT("execfile('") + fpath + wxT("',{})");
-+ wxString command = wxT("exec(open('") + fpath + wxT("').read(),{})");
- PyRun_SimpleString(command.mb_str(wxConvLocal));
- // don't use wxConvUTF8 in above line because caller has already converted
- // filepath to decomposed UTF8 if on a Mac
diff --git a/app-misc/golly/files/golly-3.3-allow-py3.patch b/app-misc/golly/files/golly-3.3-allow-py3.patch
deleted file mode 100644
index 54a047830818..000000000000
--- a/app-misc/golly/files/golly-3.3-allow-py3.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-The patch allows python3 as a python implementation.
-Ports module loading to conditional python3 support.
---- a/gui-wx/configure/configure.ac
-+++ b/gui-wx/configure/configure.ac
-@@ -19,7 +19,7 @@ AC_ARG_WITH([python-shlib], [AS_HELP_STRING([--with-python-shlib=ARG],
- , [with_python_shlib=check])
- AC_ARG_VAR([GOLLYDIR], [golly data directory [default=DATADIR/golly]])
- AC_ARG_VAR([PERL], [Perl 5 interpreter])
--AC_ARG_VAR([PYTHON], [Python 2 interpreter])
-+AC_ARG_VAR([PYTHON], [Python interpreter])
-
- # Check for build tools:
- m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
-@@ -76,7 +76,7 @@ AS_IF([test "x$enable_perl" = xyes], [
- ])
-
- # Find Python
--AC_PATH_PROGS(PYTHON, [python2 python])
-+AC_CHECK_PROGS(PYTHON, [python python3 python2])
- AS_IF([test "x$PYTHON" = x], [AC_MSG_ERROR([missing Python])])
- AC_SUBST([PYTHON_INCLUDE], [-I"'`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())"`'"])
- AS_IF([test "x$with_python_shlib" = xcheck],
---- a/gui-wx/wxpython.cpp
-+++ b/gui-wx/wxpython.cpp
-@@ -90,6 +90,12 @@
- #include <Python.h>
- #endif
-
-+#if PY_MAJOR_VERSION >= 3
-+ // python-3 got rid of int/log distinction
-+ #define PyInt_AsLong PyLong_AsLong
-+ #define PyInt_FromLong PyLong_FromLong
-+#endif
-+
- #ifdef USE_PYTHON_DYNAMIC
-
- #ifndef __WXMAC__
-@@ -3268,6 +3274,22 @@ static PyMethodDef py_methods[] = {
- { NULL, NULL, 0, NULL }
- };
-
-+#if PY_MAJOR_VERSION >= 3
-+static PyModuleDef golly_module = {
-+ PyModuleDef_HEAD_INIT,
-+ "golly", /* name */
-+ NULL, /* doc */
-+ -1, /* size */
-+ py_methods, /* methoods */
-+};
-+
-+PyMODINIT_FUNC
-+PyInit_golly(void)
-+{
-+ return PyModule_Create(&golly_module);
-+}
-+#endif
-+
- // =============================================================================
-
- bool pyinited = false; // InitPython has been successfully called?
-@@ -3280,6 +3302,13 @@ bool InitPython()
- if (!LoadPythonLib()) return false;
- #endif
-
-+ #if PY_MAJOR_VERSION >= 3
-+ // Autoload 'golly' builtin module at interpreter start.
-+ if (PyImport_AppendInittab("golly", PyInit_golly) == -1) {
-+ Warning(_("Error: could not extend in-built modules table\n"));
-+ }
-+ #endif
-+
- // only initialize the Python interpreter once, mainly because multiple
- // Py_Initialize/Py_Finalize calls cause leaks of about 12K each time!
- Py_Initialize();
-@@ -3287,9 +3316,12 @@ bool InitPython()
- #ifdef USE_PYTHON_DYNAMIC
- GetPythonExceptions();
- #endif
--
-- // allow Python to call the above py_* routines
-- Py_InitModule((char*)"golly", py_methods);
-+
-+ // Python-3 uses module constructor
-+ #if PY_MAJOR_VERSION < 3
-+ // allow Python to call the above py_* routines
-+ Py_InitModule((char*)"golly", py_methods);
-+ #endif
-
- // catch Python messages sent to stderr and pass them to py_stderr
- if (PyRun_SimpleString(
diff --git a/app-misc/golly/files/golly-3.3-glife-py23.patch b/app-misc/golly/files/golly-3.3-glife-py23.patch
deleted file mode 100644
index 8b1599712508..000000000000
--- a/app-misc/golly/files/golly-3.3-glife-py23.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Use python-3 compatible syntax.
---- a/Scripts/Python/glife/__init__.py
-+++ b/Scripts/Python/glife/__init__.py
-@@ -90,7 +90,7 @@ def rule(s = "B3/S23"):
- def description(s):
- """Supply a textual description to the whole pattern."""
- for line in s.split("\n"):
-- print "#D", line
-+ print("#D", line)
-
- # --------------------------------------------------------------------
-
-@@ -161,7 +161,7 @@ class pattern(list):
- It is also the base for computing generations subsequent to N-th."""
- if N < 0:
- raise ValueError("backward evolving requested")
-- if self.__phases.has_key(N):
-+ if N in self.__phases:
- return self.__phases[N]
- M = 0
- for k in self.__phases.keys():
---- a/Scripts/Python/glife/text.py
-+++ b/Scripts/Python/glife/text.py
-@@ -173,7 +173,7 @@ def make_text (string, font='Snakial'):
- unknown = '-'
-
- for c in string:
-- if not f.has_key (c): c = unknown
-+ if not (c in f): c = unknown
- symbol = f[c]
- p += symbol (x, 0)
- x += symbol.width
diff --git a/app-misc/golly/files/golly-3.3-nondynamic-python.patch b/app-misc/golly/files/golly-3.3-nondynamic-python.patch
deleted file mode 100644
index bc1c81a61917..000000000000
--- a/app-misc/golly/files/golly-3.3-nondynamic-python.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Don't use runtime python loading via dlopen().
-
-Just link to libpython directly. That makes python dependency
-more explicit and allows catching more compile-time bugs.
---- a/gui-wx/configure/Makefile.am
-+++ b/gui-wx/configure/Makefile.am
-@@ -22,7 +22,7 @@ golly_CPPFLAGS = $(AM_CPPFLAGS) $(WX_CPPFLAGS) $(PYTHON_INCLUDE) \
- $(PERL_CPPFLAGS) $(PERL_INCLUDE) \
- $(liblua_a_CPPFLAGS) -I$(top_srcdir)/../../lua
- golly_CXXFLAGS = $(AM_CXXFLAGS) $(WX_CXXFLAGS_ONLY)
--golly_LDADD = $(WX_LIBS) libgolly.a liblua.a
-+golly_LDADD = $(WX_LIBS) $(PYTHON_LIBS) libgolly.a liblua.a
-
- if WINDOWS
- golly_LDADD += gollyres.o
---- a/gui-wx/configure/configure.ac
-+++ b/gui-wx/configure/configure.ac
-@@ -86,6 +86,16 @@ AS_IF([test "x$with_python_shlib" = xcheck],
- AS_IF([test "x$shlib" = x], AC_MSG_ERROR([could not determine Python shared library name]))
- AC_DEFINE_UNQUOTED([PYTHON_SHLIB], [$shlib])
-
-+# Find python interpreter
-+# 1. --embed is needed for python>=3.8
-+# 2. statuc check is needed because python-3.7-config outputs error to stdout, not stderr
-+if ${PYTHON}-config --libs --embed; then
-+ PYTHON_LIBS=`${PYTHON}-config --libs --embed`
-+elif ${PYTHON}-config --libs; then
-+ PYTHON_LIBS=`${PYTHON}-config --libs`
-+fi
-+AC_SUBST(PYTHON_LIBS)
-+
- # Find zlib (unless explicitly disabled)
- AS_IF([test "x$with_zlib" != xno],
- [ AC_CHECK_HEADER([zlib.h], , [AC_MSG_ERROR([missing zlib])])
---- a/gui-wx/wxpython.cpp
-+++ b/gui-wx/wxpython.cpp
-@@ -59,8 +59,12 @@
- #undef SIZEOF_SIZE_T
- #undef SIZEOF_VOID_P
- #else
-- // load Python lib at runtime
-- #define USE_PYTHON_DYNAMIC
-+ // On gentoo just link against python to make
-+ // python dependency more explicit.
-+ # if 0
-+ // load Python lib at runtime
-+ #define USE_PYTHON_DYNAMIC
-+ #endif
-
- #ifdef __UNIX__
- // avoid warning on Linux