summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /app-misc/gnote
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest2
-rw-r--r--app-misc/gnote/gnote-42.1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 554ecd6b025b..20a5f834e6d7 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,3 +1,5 @@
DIST gnote-42.0.tar.xz 3330504 BLAKE2B 847c1c66b86902c13a7e9cd349e0b1e565f046ba81809dca002bfdc07d1e3dc4e12797da90e7689d8fde886ced580da9b744ca736697d1fd933a93cc344304bd SHA512 fcdd653a29ae957faf177bacbe1bbdced186416c04a8f45f194a055914544b0679019935f482834e515a20865f358dfdfc32aa846c0fd24596cf5e569e21b997
+DIST gnote-42.1.tar.xz 3330824 BLAKE2B 0bfd6276ab8446acfd925dd44fad7bbc94afe770bd4395ad2cfa1b20e4635da681d44db13b20b65262f80959d5cecaf044bc75cc6ea4fed84c79c87d8cda0ad1 SHA512 2ff3218b571edc1dcbba1cb5db5127ecfd184883a70bc6bd88391a9679989527680abe4ffb46620e73285fb1caacc23787e2500a867886924b540dfdd7f28d87
EBUILD gnote-42.0.ebuild 1529 BLAKE2B 25b2bbbc16b22e051f3bf98dbded4ae9151b64330003b84b8b529c428fcb076d4c40f493f66a02d9138f415d7819a1dd64701785e80e3e3b961f8d501461a234 SHA512 c0e89681d3b0acb65c66d0050cedc52cdaa63c094721d57589abab87f8c7de1095d91cbfdbb0d92867d8f45eecc68e6d8f3a903001267a92d1d6caca5a0ca54f
+EBUILD gnote-42.1.ebuild 1531 BLAKE2B 701bbd0c3c162abb1e5dd6df41fe3f35b065e502934096853272238761ed9bf0590c2533550452790acafd4bd01d7300df81cc0ab759fc08dd508664c50419e7 SHA512 1199fc10659751737c226278e3ffad458c3ddb4a8ff4e57c63c807f72d82c7eb6895798e9db823c6b60500264bbc42d2d2e17196b30a4335517f3a8f02b4c9a9
MISC metadata.xml 343 BLAKE2B 7ee97c51a3909fa5375a7ad9ee680ef0e52cbf09098f385eb3a11441af6a31b76e8c7674a0b57d7adc8a07546b9b5c31f8eb4007e58e030cf348fc5ca2499718 SHA512 d304542c83029fc3ff18100e14539f9b9a01474b5847e1495d4f01ee48d8b16f06a7efeb3919a9f3f1686770f23b30185441cfacd4c081eab4a34c21b3307a50
diff --git a/app-misc/gnote/gnote-42.1.ebuild b/app-misc/gnote/gnote-42.1.ebuild
new file mode 100644
index 000000000000..ffd488033aaf
--- /dev/null
+++ b/app-misc/gnote/gnote-42.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.62:2[dbus]
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.22.20:3.0
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=app-text/gspell-1.6.0:=
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}