summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-misc/gnote
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest2
-rw-r--r--app-misc/gnote/gnote-3.36.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 225396720633..c0cc80a85ca3 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,3 +1,5 @@
DIST gnote-3.30.0.tar.xz 4017364 BLAKE2B e53240162d4814a0f004863ca5d309dce0b428d8ce4f7e8dc64c0ce683a830ebedc4809191e55818dba98de7d968413ae080f86367abacf3e4f3a404bbd62157 SHA512 7c1348b9fdbc84ea8cc74e214de50b594a1585031a40406ba73a8635362ef1769a37dbce79347188983970debf72d3c0f81523739a48bf27823f0233cc6cfd2b
+DIST gnote-3.36.1.tar.xz 3512000 BLAKE2B 00f5f8049085c855722f92fb3231684d53c4a15b96b7148a2a810d8fdd4c02b22510f4c4f9296fd7e2f4ba96e44d55215f71a2eb78ecb60170f8bb7ffbdef6ef SHA512 4c0c9d469836366a7886928beb0b47c48e60ee41591de193b9af597214f373c2c14b25745f6238ccbede8df8e7d4d83f39a34aed1b155895479bba3e043d2cce
EBUILD gnote-3.30.0.ebuild 1606 BLAKE2B 74048690188d8e0c430082d90bde2b84b224437b0eb1cf5ba6ef094523fc985205ad1fbc6b5f0d9a5190f662180e1feed1ef9f27512bdadac4cffa00702035b1 SHA512 fc3688fa697ba4fc36b2140e31951cfae2b69092161bee5ec3e333bcae7b1167798c2a4b6796e469da5fa9ace62419bd20e5882f12f5dbb9464fec459019a0fd
+EBUILD gnote-3.36.1.ebuild 1548 BLAKE2B 6edd95f88dc91cb497d0c381d70ff6372ecdbfb576fea1b52225ccefe7e6ef1eecf1ff35fa2131c1778679c119a82121488f3f9777e8a01176324ffc4e9c01a5 SHA512 9a3d035a3eec9d4b03f3209cde5d15eb0ba39c882213999972eac931301d5a64f053c3927d79d293461047ad8ba6c4b5a7eff1665aa546c4ff3a847caaca76ab
MISC metadata.xml 342 BLAKE2B 51d98560833845aa6d1f2b9f4c85021fd317434efcd81ba31d106c7b4945acd23cfefc2de2a601ffef3d330adcf93ec0377f69107fa37771d80f7dff056d32ff SHA512 c68c058e279222cc9293a5b97fbf450f95a940a70a32b1adcac3e6276783d2bcc545f39895e92e7bd62c9ac5dc98139dc9800513c2a828895ba1fcf023227d21
diff --git a/app-misc/gnote/gnote-3.36.1.ebuild b/app-misc/gnote/gnote-3.36.1.ebuild
new file mode 100644
index 000000000000..95d5527ca525
--- /dev/null
+++ b/app-misc/gnote/gnote-3.36.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gspell-1.6.0:=
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}