summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/gnote
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest3
-rw-r--r--app-misc/gnote/gnote-3.24.1.ebuild71
-rw-r--r--app-misc/gnote/metadata.xml11
3 files changed, 85 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
new file mode 100644
index 000000000000..e7efdbb20dc9
--- /dev/null
+++ b/app-misc/gnote/Manifest
@@ -0,0 +1,3 @@
+DIST gnote-3.24.1.tar.xz 3310012 BLAKE2B b6167dbb2461e574e4f21b2f227eb9a3c89708ddd15a561146faa044130e5c9ccc6d64b4923c30726160ee35d4ab5a0ae04b1593e74af2fa6566582af9bc1f18 SHA512 759fb2984312a3e3d5aed9b79f2309021b69df57b820d34814a5d3d9b5c9201abc6e50d83bf64f30974991d779b0b85e599435a24ee1326b867a2a4be8e0f37e
+EBUILD gnote-3.24.1.ebuild 1547 BLAKE2B 8a0e15ea352c054b0d777386d798334f921e5778c462822e932a5f21f0442b7bd71738f4ebc91ada4f6eb58c60af5d4876bc0265d0d283fcbe925cc4c8ce2bd7 SHA512 6144bccd5cd942f967729912371ff82622874cde18bfda99f905322a9fa16d3e52d0d973d17d4b2da5c92d93ada3eadd19f9f90db57bdddfa2b03cbeb12aff7d
+MISC metadata.xml 342 BLAKE2B 51d98560833845aa6d1f2b9f4c85021fd317434efcd81ba31d106c7b4945acd23cfefc2de2a601ffef3d330adcf93ec0377f69107fa37771d80f7dff056d32ff SHA512 c68c058e279222cc9293a5b97fbf450f95a940a70a32b1adcac3e6276783d2bcc545f39895e92e7bd62c9ac5dc98139dc9800513c2a828895ba1fcf023227d21
diff --git a/app-misc/gnote/gnote-3.24.1.ebuild b/app-misc/gnote/gnote-3.24.1.ebuild
new file mode 100644
index 000000000000..efeb2abea8e1
--- /dev/null
+++ b/app-misc/gnote/gnote-3.24.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-misc/gnote/metadata.xml b/app-misc/gnote/metadata.xml
new file mode 100644
index 000000000000..9c70dba0d6b9
--- /dev/null
+++ b/app-misc/gnote/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tsuna/boost.m4</remote-id>
+ </upstream>
+</pkgmetadata>