summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /app-misc/gnote
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest2
-rw-r--r--app-misc/gnote/gnote-40.2.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 0141d912c696..3b9b892204be 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,4 +1,6 @@
AUX gnote-3.38.1-cstddef.patch 988 BLAKE2B 8281bd3b515d642b57e49e365b76b134a3ccc9021b4b95b46934d4713f39cb107a644db948cac73175fa6dcdbdf566639894521b1415957af2dc8b661aca08e1 SHA512 3f4cdb300299fc224f3c5fd2cc8a4f8d47a7eb41af47eb233555f714879cdf1d0e294c5045a4fb89b4b721b6029f5c38dac7fee5d6c1c11461efe0523a3edefe
DIST gnote-40.1.tar.xz 3420216 BLAKE2B a84604b25301fb0332da161a7f1f258542f1dfa16a02f34e700280e87393a3eb6d9005a5ed18204b91d0fccea2f6e44738789ab57dae543707650bfce55165c8 SHA512 6f4286fef18b060bb46c1c9f43772df7d9d913d6d1e3e3801e38e277fa660aa213e46f4a825788795f153821f705bbea22df7d1ff90ee949752497274455ad37
+DIST gnote-40.2.tar.xz 3422560 BLAKE2B d7d7fa862e02c1d889c736ae733db503a06db93cfc79c12bd1efa89acbe4a5825d0cf0cab00cfa916566002c1b838d118b37f5b0204f20ac9fcab2f892cccf52 SHA512 e1dc3ed4fb7b7c4f346a4a1e63a2e357b197375caf5d1d2026c159cfda012ace76ad598ecaf8e7d7649fb80abedc0cd4febd369160ddaf4510cfcc6b41185aed
EBUILD gnote-40.1.ebuild 1561 BLAKE2B d408ae3b6729f5b9bf8e780898224abfbbe4057caa5c50d739c9fbff644f4071ccffa8017a83ced5cd2ef6dbb8aa82ec9fa2116e84b41a1fad30626f0ae772ea SHA512 11d3a079ee001ab75c7df3c382e5dc58de58db141eb5010f694f86c203f6ce4eb2ae96001738a497bc36572d83e04cf4e03e11c58a0cc07efbcc4694c694831b
+EBUILD gnote-40.2.ebuild 1563 BLAKE2B e9112a82cb20c0bfa6cb0d19c2cbc811fbc42251e76f84026cb5e849d728f7042315e4d7d3cafca19dd948b043d5054da938ff87312ed3ae20e09965a991d139 SHA512 070dee31791766de946e674387c3a65e57c5385d58571b07a45d86caa4b251d892064a38d20e94aaa1ebb03c828fe363b66f562af4deb7b7dd31eba5a237ed04
MISC metadata.xml 342 BLAKE2B 51d98560833845aa6d1f2b9f4c85021fd317434efcd81ba31d106c7b4945acd23cfefc2de2a601ffef3d330adcf93ec0377f69107fa37771d80f7dff056d32ff SHA512 c68c058e279222cc9293a5b97fbf450f95a940a70a32b1adcac3e6276783d2bcc545f39895e92e7bd62c9ac5dc98139dc9800513c2a828895ba1fcf023227d21
diff --git a/app-misc/gnote/gnote-40.2.ebuild b/app-misc/gnote/gnote-40.2.ebuild
new file mode 100644
index 000000000000..d59f76c84cde
--- /dev/null
+++ b/app-misc/gnote/gnote-40.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gspell-1.6.0:=
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.22.20:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.22.20:3
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+PATCHES=("${FILESDIR}"/${PN}-3.38.1-cstddef.patch)
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}