summaryrefslogtreecommitdiff
path: root/app-misc/gnote/gnote-44.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 02:49:03 +0100
commit293b7d4c34fb5285799bb5149595e29dae34cac9 (patch)
treeea6bb71bb2bbdb570695963f3127e5299e1ce1ba /app-misc/gnote/gnote-44.1.ebuild
parent1e3cb587fdf303df9aeb0b00a1a45585e18f6134 (diff)
gentoo auto-resync : 22:07:2023 - 02:49:03
Diffstat (limited to 'app-misc/gnote/gnote-44.1.ebuild')
-rw-r--r--app-misc/gnote/gnote-44.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/gnote/gnote-44.1.ebuild b/app-misc/gnote/gnote-44.1.ebuild
new file mode 100644
index 000000000000..d23217101987
--- /dev/null
+++ b/app-misc/gnote/gnote-44.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.62:2[dbus]
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.22.20:3.0
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ >=app-text/gspell-1.6.0:=
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}