summaryrefslogtreecommitdiff
path: root/app-misc/glastree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/glastree
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/glastree')
-rw-r--r--app-misc/glastree/Manifest4
-rw-r--r--app-misc/glastree/files/glastree-posix-make.patch16
-rw-r--r--app-misc/glastree/glastree-1.04.ebuild28
-rw-r--r--app-misc/glastree/metadata.xml5
4 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/glastree/Manifest b/app-misc/glastree/Manifest
new file mode 100644
index 000000000000..84ca0da76890
--- /dev/null
+++ b/app-misc/glastree/Manifest
@@ -0,0 +1,4 @@
+AUX glastree-posix-make.patch 559 BLAKE2B be055c7114bd0ddf52aed5b09ccba2110b15167019146ccddd411aba48e07f6d8091756a47034915ff7c253d166137e0e34a7fa92cb3263bff53886bd4a37aa8 SHA512 fe76f51fc869ce03b9e44270045b6b92c8d69e4fac5878eee7167899633aad1fe2d68648310f3ba6edd47360dcb93c7d0dbda2323e9c2d44adf0d984708a174d
+DIST glastree-1.04.tar.gz 5846 BLAKE2B b380b577a712f08b0a3ec89627d9f8bd20c76244ab19c8e76d27ac2fa08b0242381c280430fafe8a43bef78de8954d4660051d7648550c4ecd789a8941b55a4d SHA512 81b819bc91780f42f945db13efc97faadd661c3272007dc0b90ed998776d3fc0fbe406249f069f0065271208c9f6ccd0488021d384e05d5b9da39311bec8f94d
+EBUILD glastree-1.04.ebuild 635 BLAKE2B e4ff8181d2701c2933136ddc98f6685e2c43e8c70d8993d2d1fa2d709a441c2191a005a0a91e275c5802aa310b0359cd4d8270bf36960cdc3d44e9bd1cb8fc45 SHA512 cd9989a5c734ba1df00af5dc79a34cb7ff4c3ffc9367a9dda494dcdb6bdd31a201fc3b95b664a79014c22ac895df4fdb20daca5968b124d10e18773939853406
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-misc/glastree/files/glastree-posix-make.patch b/app-misc/glastree/files/glastree-posix-make.patch
new file mode 100644
index 000000000000..07e4bf6ec91a
--- /dev/null
+++ b/app-misc/glastree/files/glastree-posix-make.patch
@@ -0,0 +1,16 @@
+Make sure the perl code is valid both with and without the backslashes.
+Some make versions strip them, others don't.
+
+--- glastree-1.04/Makefile
++++ glastree-1.04/Makefile
+@@ -24,8 +24,8 @@
+
+ install:
+ @perl -e 'eval "use Date::Calc"; \
+- print "Checking for prereq Date::Calc..."; \
+- if ($$@) { print "\nThis program requires the Date::Calc module.\n"; exit 1; } \
++ print "Checking for prereq Date::Calc..."; if ($$@) { \
++ print "\nThis program requires the Date::Calc module.\n"; exit 1; } \
+ print " OK\n"; '
+
+ $(INSTALL) -d $(INSTROOT)/$(INSTBIN)
diff --git a/app-misc/glastree/glastree-1.04.ebuild b/app-misc/glastree/glastree-1.04.ebuild
new file mode 100644
index 000000000000..892b11bc30aa
--- /dev/null
+++ b/app-misc/glastree/glastree-1.04.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="glastree is a poor mans snapshot utility using hardlinks written in perl"
+HOMEPAGE="http://www.igmus.org/code/"
+SRC_URI="http://www.igmus.org/files/${P}.tar.gz"
+DEPEND="dev-lang/perl
+ dev-perl/Date-Calc"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+LICENSE="public-domain"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-posix-make.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/man/man1
+ emake INSTROOT="${D}"/usr INSTMAN=share/man install
+ dodoc README CHANGES THANKS TODO
+}
diff --git a/app-misc/glastree/metadata.xml b/app-misc/glastree/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-misc/glastree/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>