summaryrefslogtreecommitdiff
path: root/app-misc/getopt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/getopt/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/getopt/files')
-rw-r--r--app-misc/getopt/files/getopt-1.1.4-irix.patch17
-rw-r--r--app-misc/getopt/files/getopt-1.1.5-libintl.patch11
-rw-r--r--app-misc/getopt/files/getopt-1.1.5-setlocale.patch12
-rw-r--r--app-misc/getopt/files/getopt-1.1.6-longrename.patch70
4 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/getopt/files/getopt-1.1.4-irix.patch b/app-misc/getopt/files/getopt-1.1.4-irix.patch
new file mode 100644
index 000000000000..0c344a80131a
--- /dev/null
+++ b/app-misc/getopt/files/getopt-1.1.4-irix.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/show_bug.cgi?id=211499
+
+--- gnu/getopt.c.dist
++++ gnu/getopt.c
+@@ -69,12 +69,7 @@
+ #include <unistd.h>
+ #endif /* GNU C library. */
+
+-#ifdef VMS
+-#include <unixlib.h>
+-#if HAVE_STRING_H - 0
+ #include <string.h>
+-#endif
+-#endif
+
+ #if defined (WIN32) && !defined (__CYGWIN32__)
+ /* It's not Unix, really. See? Capital letters. */
diff --git a/app-misc/getopt/files/getopt-1.1.5-libintl.patch b/app-misc/getopt/files/getopt-1.1.5-libintl.patch
new file mode 100644
index 000000000000..b40367105ed0
--- /dev/null
+++ b/app-misc/getopt/files/getopt-1.1.5-libintl.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2012-12-28 11:40:09.524686698 +0100
++++ Makefile 2012-12-28 11:41:20.646157275 +0100
+@@ -61,7 +61,7 @@
+ -$(RM) $(objects) $(binaries)
+
+ getopt: $(objects)
+- $(CC) $(LDFLAGS) -o $@ $(objects)
++ $(CC) $(LDFLAGS) -o $@ $(objects) $(LIBINTL)
+
+ install: getopt install_po
+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
diff --git a/app-misc/getopt/files/getopt-1.1.5-setlocale.patch b/app-misc/getopt/files/getopt-1.1.5-setlocale.patch
new file mode 100644
index 000000000000..2d302d9c6a67
--- /dev/null
+++ b/app-misc/getopt/files/getopt-1.1.5-setlocale.patch
@@ -0,0 +1,12 @@
+setlocale: we need locale.h for LC_ALL on OpenIndiana
+
+--- getopt-1.1.5/nls.h
++++ getopt-1.1.5/nls.h
+@@ -40,6 +40,7 @@
+ #undef setlocale
+ #define setlocale(Category,Locale) /* empty */
+ #else /* not WITHOUT_GETTEXT */
++#include <locale.h>
+ #include <libintl.h>
+ #define _(Text) gettext (Text)
+ #endif /* WITHOUT_GETTEXT */
diff --git a/app-misc/getopt/files/getopt-1.1.6-longrename.patch b/app-misc/getopt/files/getopt-1.1.6-longrename.patch
new file mode 100644
index 000000000000..f2b4ba79a090
--- /dev/null
+++ b/app-misc/getopt/files/getopt-1.1.6-longrename.patch
@@ -0,0 +1,70 @@
+--- a/Makefile
++++ b/Makefile
+@@ -32,7 +32,7 @@ MSGFMT=msgfmt
+ LANGUAGES = ca cs da de es et eu fi fr gl hr hu id it ja nl pl pt_BR ru sl sv tr uk vi zh_CN zh_TW
+ MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
+
+-CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)\" -Dprogram_version=\"$(VERSION)\"
++CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITHOUT_GETTEXT=$(WITHOUT_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX -Dprogram_invocation_short_name=\"$(PACKAGE)-long\" -Dprogram_version=\"$(VERSION)\"
+ ifeq ($(LIBCGETOPT),0)
+ CPPFLAGS+=-I./gnu
+ endif
+@@ -81,7 +81,7 @@ install_po: all_po
+ for lang in $(LANGUAGES) ; do \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(INSTALL) -m 755 -d $(DESTDIR)$$dir ;\
+- $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt.mo ;\
++ $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt-long.mo ;\
+ done
+ clean_po:
+ $(RM) $(MOFILES)
+--- a/getopt-parse.bash
++++ b/getopt-parse.bash
+@@ -19,7 +19,7 @@
+ # Note that we use `"$@"' to let each command-line parameter expand to a
+ # separate word. The quotes around `$@' are essential!
+ # We need TEMP as the `eval set --' would nuke the return value of getopt.
+-TEMP=`getopt -o ab:c:: --long a-long,b-long:,c-long:: \
++TEMP=`getopt-long -o ab:c:: --long a-long,b-long:,c-long:: \
+ -n 'example.bash' -- "$@"`
+
+ if [ $? != 0 ] ; then echo "Terminating..." >&2 ; exit 1 ; fi
+--- a/getopt-parse.tcsh
++++ b/getopt-parse.tcsh
+@@ -26,7 +26,7 @@
+ # as a list. The ':q` copies that list without doing any substitutions:
+ # each element of argv becomes a separate argument for getopt. The braces
+ # are needed because the result is also a list.
+-set temp=(`getopt -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
++set temp=(`getopt-long -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
+ if ($? != 0) then
+ echo "Terminating..." >/dev/stderr
+ exit 1
+--- a/getopt.c
++++ b/getopt.c
+@@ -344,12 +344,12 @@ static void __attribute__ ((__noreturn__)) print_help(void)
+ fputs(_(" -q, --quiet Disable error reporting by getopt(3)\n"), stderr);
+ fputs(_(" -Q, --quiet-output No normal output\n"), stderr);
+ fputs(_(" -s, --shell <shell> Set shell quoting conventions\n"), stderr);
+- fputs(_(" -T, --test Test for getopt(1) version\n"), stderr);
++ fputs(_(" -T, --test Test for getopt-long(1) version\n"), stderr);
+ fputs(_(" -u, --unquoted Do not quote the output\n"), stderr);
+ fputs(USAGE_SEPARATOR, stderr);
+ fputs(USAGE_HELP, stderr);
+ fputs(USAGE_VERSION, stderr);
+- fprintf(stderr, USAGE_MAN_TAIL("getopt(1)"));
++ fprintf(stderr, USAGE_MAN_TAIL("getopt-long(1)"));
+ exit(PARAMETER_EXIT_CODE);
+ }
+
+--- a/nls.h
++++ b/nls.h
+@@ -29,7 +29,7 @@
+ #ifndef GETOPT_NLS
+ #define GETOPT_NLS
+
+-#define PACKAGE "getopt"
++#define PACKAGE "getopt-long"
+
+ #if WITHOUT_GETTEXT
+ #define _(Text) (Text)